Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We have been using FOG installed on Ubuntu to image computers and have now started creating an image as a Hyper-V virtual machine (an image created as a virtual machine was a recommendation to us, and we are running Hyper-V hosts so we created it as a Hyper-V virtual).

We are having trouble getting the kernel that FOG is using to read the hard drive of the virtual (and it won't pass the Disk check of FOG's Compatibility test), so we assume that the drivers in the kernel don't support what the Hyper-V virtual uses.

We have now tried to compile a new kernel (3.10) using the .Config file that FOG supplies and the command sudo make xconfig which brings up a Kernel Configurator, but where it says Microsoft Hyper-V guest support there is no tickbox next to it to include it in the kernel? Have tried ticking Virtualization Drivers and Virtualization, and then compiled the kernel, but it hasn't seemed to fix our problem. We are trying to do this on an installation of Ubuntu 12.04.

Does anyone know how to include Hyper-V support in the kernel, and whether or not it will actually be a solution for our problem? Any other ideas?

Please bare in mind, we do not know much about Linux/Unix operating systems and have never compiled a kernel before.

share|improve this question

Not sure if this is still an issue for you but thought I would answer your question anyway. You need to enable Linux Guest support first, I ran into the same issue recently. Go to - Processor type and features -> Linux guest support Enable that and you will then be able to select the Microsoft Hyper-V options. Note: If you do enable the option it defaults to enabling the paravirtualization code so go into Linux guest support and disable it.

Hopefully that fixes things for you.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.