Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I installed virt-manager and I am unable to make it work.

I have tried some of the previously posted answers with no success. I've verified that:

  • The libvirt-bin package is installed
  • The libvirtd daemon has been started
  • I am a member of the libvirtd group
  • libvirt URI is: qemu:///system

This is the error I get when trying to run virt-manager:

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/", line 1027, in _open_thread
    self.vmm = self._try_open()
  File "/usr/share/virt-manager/virtManager/", line 1009, in _try_open
  File "/usr/lib/python2.7/dist-packages/", line 102, in openAuth
    if ret is None:raise libvirtError('virConnectOpenAuth() failed')
libvirtError: Failed to connect socket to '/var/run/libvirt/libvirt-sock': Permission     denied
share|improve this question
Please, edit your question to include the output of ls -la /var/run/libvirt/. –  Eric Carvalho Jul 11 '13 at 14:32

3 Answers 3

I had the same issue. Try this guide it's works for me. Don't forget relogin after add user to group 'libvirtd'

share|improve this answer
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Eric Carvalho Jan 30 '14 at 19:20

Try to add this line to /etc/libvirt/libvirtd.conf

listen_tls = 0

then restart lirvirt by:

/etc/init.d/libvirt-bin restart
share|improve this answer

You may have to log out and log back in.

Assuming /etc/libvirt/libvirtd.conf has:

# Set the UNIX domain socket group ownership. This can be used to
# allow a 'trusted' set of users access to management capabilities
# without becoming root.
# This is restricted to 'root' by default.
unix_sock_group = "libvirtd"

# Set the UNIX socket permissions for the R/O socket. This is used
# for monitoring VM status only
# Default allows any user. If setting group ownership, you may want to
# restrict this too.
unix_sock_ro_perms = "0777"

# Set the UNIX socket permissions for the R/W socket. This is used
# for full management of VMs
# Default allows only root. If PolicyKit is enabled on the socket,
# the default will change to allow everyone (eg, 0777)
# If not using PolicyKit and setting group ownership for access
# control, then you may want to relax this too.
unix_sock_rw_perms = "0770"

It should work if your user is a member of the libvirtd group.

Check if your user is supposed to be in the group, example user vagrant:

$ cat /etc/group|grep $USER

If your user is not in the group, you'll need to add it:

$ sudo usermod -a -G libvirtd $USER

If your user was already in the group in /etc/group, then check the output of groups:

$ groups
vagrant libvirtd

If you don't see libvirtd, you'll need to log out and log back in.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.