Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a TrueCrypt volume created under Windows 7. Some folders and file names contain Cyrillic symbols. When mounting the volume in Ubuntu 10.10, I see question marks instead of those letters. Is there a solution, or should I avoid non-ASCII symbols if I want to open the volume in Windows and Ubuntu?

share|improve this question
add comment

1 Answer

I had the same problem. Here's how I resolved it.

The truecrypt volume you created was most likely formatted as FAT32. When mounting FAT in Linux default charset is iso8859-1, although long filenames in Windows are stored on disk in Unicode format.

Solution: specify iocharset=utf8 in Truecrypt for Mount options (globally in preferences or for specific volume in advanced options).

share|improve this answer
    
Thank you! I apologize for slow response, I don't have Linux at hand to check this. I'll approve the answer as soon as I test it on my system. –  texnic Nov 20 '11 at 12:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.