Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've recently purchased a Lenovo Yoga 13 and put Ubuntu 13.04 on it last night. I was unable to get wireless to come on and thought that I would mess around with it today. Today I have followed the detailed 'how-to' at: http://majordamo.wordpress.com/2013/05/15/getting-the-realtek-rtl8723ae-bt-wi-fi-card-to-work-on-a-lenovo-yoga-13-on-linux-mint-13-ubuntu-12-10/ The problem is I can not download and install the required headers as I do not have ANY internet connection on this device. Is there any way for me to get them on a flash drive and bring them to the Lenovo?

Any and all help is appreciated. Thanks

share|improve this question

6 Answers 6

up vote 13 down vote accepted

That how-to link is outdated; the latest version of the rtl8723au wireless driver can be found at https://github.com/lwfinger/rtl8723au.

Here are the steps to install:

git clone https://github.com/lwfinger/rtl8723au.git
cd rtl8723au/
make
sudo make install
sudo modprobe 8723au

When you update the kernel, you'll need to run these steps again to get wireless working (except for the git clone). To fetch the latest version of the code, use git pull.

The bluetooth driver for that chip can then be found at https://github.com/lwfinger/rtl8723au_bt and installed like this:

git clone https://github.com/lwfinger/rtl8723au_bt.git
cd rtl8723au_bt/
make
sudo make install
share|improve this answer
2  
It has to be said that you need to make sure that you modprobe exactly as it says here. I kept doing sudo modprobe rtl8723ae, which turns out wasn't the right one. –  Hosh Sadiq Nov 5 '13 at 21:50
    
My wifi runs a little slow but it works and so far the best answer I've found. Thanks. +1 –  Kirill Fuchs Nov 9 '13 at 17:27
    
I followed this advice and it worked great. After updating the kernel I was going to repeat the procedure but this time I cannot seem to build it. When I issue the make command I get "CONFIG_X86_X32 enabled but no binutils support". Any ideas why? –  Dr. Mike Nov 22 '13 at 8:05
1  
ATTENTION: The bluetooth driver caused a kernel panic for me during (recovery) boot (kernel 3.13.0-24generic on ubuntu gnome 14.04). To fix it merge github.com/lwfinger/rtl8723au_bt/pull/9 in. –  GameScripting Apr 26 at 20:38
    
answer's like these are exactly what i love about ubuntu, git, and stackoverflow. God bless america ;) –  Elad Katz Jun 6 at 4:12

The author merged in DKMS support a few months ago, but didn't integrate it into the make install process. Following these commands will add it to DKMS so you don't have to manually recompile after every kernel update.

From https://github.com/lwfinger/rtl8723au/blob/master/README.dkms:

To get DKMS to work:

  • Install dkms
  • Copy this source to the directory /usr/src/8723au-0.1/
  • Run (as root):

    dkms add -m 8723au -v 0.1
    
  • Test a build:

    dkms build -m 8723au -v 0.1
    

From now on this driver should be available for any new kernels.

share|improve this answer

Post #6 here, although it is for a different driver, describes the process to download and install linux-headers and build-essential on a flash drive, transfer them to the Yoga and install them. http://ubuntuforums.org/showthread.php?t=2050126 It is cumbersome and tedious, but it can be done.

share|improve this answer

I made a youtube video to walk everyone through this it is at http://www.youtube.com/watch?v=H3WdsSHo5Sw justfollow the instructions in the notes section or watch the video very carefully.

Sorry I just made a new channel and had to change the link

share|improve this answer

Ive used this guide after many reinstalls. Suddenly I am getting a prompt for a password ( not necessary before ) and this error:

Username for 'https: // github . com': majordamo
Password for 'https:// majordamo @ github.com': error: The requested URL returned error: 403 while accessing https://github.com/lwfinger/rt18723au.git/info/refs fatal: HTTP request failed

ANyone else haveing problems with git clone?

( I've added spaces to include the links so that it breaks the no more than 2-link rule, which is stupid for a site like this )

share|improve this answer
    
What version did you install? (of Ubuntu) –  AbsoluteZ3r0 Apr 13 at 15:50
    
If you have a new question, please ask it by clicking the Ask Question button. Include a link to this question if it helps provide context. –  v2r Apr 13 at 16:28
    
You've copied the url incorrectly (rt18723au when it should be rtl8723au) –  david Apr 30 at 14:35

Did you have any luck? Curious if the USB option worked.

share|improve this answer
2  
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. –  Warren Hill Nov 18 '13 at 15:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.