Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I have a dual-booted Windows 8-Ubuntu 13.04 system. As usual, by default, the Ubuntu grub menu comes up as soon as we boot. Similar questions have been asked before, and the reply to each of them was Grub Customiser and EasyBCD. My problem is that as soon as I restart my system, the changes in EasyBCD installer get reverted. Please provide me with a solution to this.

This is my boot-menu as in EasyBCD:

enter image description here

Now I go to the boot menu, set priority for Windows 8 the highest and in BCD deployment hit 'Write MBR'. Yet, when I restart, no changes take place and it reverts back to the same order.

share|improve this question

marked as duplicate by Luis Jul 10 '13 at 18:41

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Did you try the section "REPAIRING THE BOOT" from askubuntu.com/questions/221835/… –  Luis Jul 10 '13 at 17:45
    
Actually, there isn't any problem with the boot, I just want the sky-blue Windows OS selection screen instead of the Purple Ubuntu one. –  Ranveer Jul 10 '13 at 17:50
    
Wait, what you want is to install Ubuntu inside Windows (Hence the sky-blue selection screen) this is not going to happen any time soon. You can thank Microsoft for that and how difficult the Wubi installer handles Ubuntu on a Windows 8 computer. See the same answer I mentioned about Wubi (Which is what you are looking for) and why it does not work on Windows 8 pre-installed systems. –  Luis Jul 10 '13 at 18:00
    
By previously asked questions I was referring to this askubuntu.com/questions/230878/… –  Ranveer Jul 10 '13 at 18:05
    
in that case the user installed Ubuntu and Windows by himself (Not pre-installed so not in UEFI). The problem will still be there since Windows 8's boot manager is totally different than previous versions and it has brought more problems than solutions to a Dual-Boot system. If you did it as mentioned by the user that answered then you either have a hardware incompatibility or EasyBCD simply does not work with the current settings (Which amazes me taking into consideration the amount of problems I have encountered trying to boot both OS). I would suggest to ask in the EasyBCD Forums. –  Luis Jul 10 '13 at 18:12

1 Answer 1

up vote 0 down vote accepted

This is not gonna happen. I doubt that windows startup manager will see ubuntu partitions. It may but it will take you searching and playing around with settings. Rule of Thumb is : install windows first, install Linux after, allow Grub overwrite MBR and use grub. I guess this is not the answer you were looking for... ?

share|improve this answer
    
Actually, there is a way to do that. And as I said, there have been solutions to this previously, involving EasyBCD. Now my system doesn't accept the changes made by EasyBCD and reverts to default every time I boot. –  Ranveer Jul 10 '13 at 17:56
    
@Ranveer It is impossible to find a solution to what you want. The only way for the boot to use the Windows style one (Even for EasyBCD) would be for you to remove Windows, disable UEFI and any other related EFI options and then install Windows 8 again followed by a Wubi installation of Ubuntu. –  Luis Jul 10 '13 at 18:02
    
So has this been done in Legacy? askubuntu.com/questions/230878/… –  Ranveer Jul 10 '13 at 18:04
    
@Ranveer Yes. OP there says he's not using UEFI. –  gertvdijk Jul 10 '13 at 18:23
    
Alright thanks! –  Ranveer Jul 10 '13 at 18:27

Not the answer you're looking for? Browse other questions tagged or ask your own question.