Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded the kernel to 3.5.0-36-generic by running the following from the LTSEnablementStack guide:

sudo apt-get install --install-recommends linux-generic-lts-quantal xserver-xorg-lts-quantal libgl1-mesa-glx-lts-quantal

and ran sudo apt-get upgrade afterwards for good measure. Now I'm seeing the following issues:

First of all, sudo apt-get update outputs:

The following packages have been kept back:
    linux-generic linux-headers-generic linux-image-generic

these are listed under Update Manager as updates for 3.2 with Description such as:

Installed version: 3.2.0.41.39
Available version: 3.2.0.49.59

in addition to 3x Recommended updates corresponding to the three packages above:

  • Header files related to Linux kernel version 3.2.0
  • Linux kernel headers for version 3.2.0 on 64bit x86 SMP
  • Linux kernel image for version 3.2.0 on 64bit x86 SMP

The question is, why am I being recommended 3.2 kernel upgrades when I'm clearly already on the new kernel (uname -r and grub screen confirm)? How do I get rid of them? Is there any harm in actually going through with the updates?

Can I safely assume that because grub is using the new kernel, it should be ok to accept all sorts of updates to past kernels?

share|improve this question
    
Have you tried to remove the 3.2 kernel(s) you have? You can get a listing using dpkg --get-selections | grep "linux-image\|linux-headers" –  Salem Jul 10 '13 at 17:54
    
Here's the list I get when running that: linux-headers-3.2.0-23 install linux-headers-3.2.0-23-generic install linux-headers-3.5.0-36 install linux-headers-3.5.0-36-generic install linux-headers-generic install linux-headers-generic-lts-quantal install linux-image-3.2.0-23-generic install linux-image-3.5.0-36-generic install linux-image-generic install linux-image-generic-lts-quantal install Should I go ahead and remove everything that's 3.2 and/or not -lts-quantal? –  Alexandr Kurilin Jul 10 '13 at 23:02
1  
If you don't use them you can remove any 3.2 kernel packages. In my computer, when I try to boot a 3.2 kernel with EnablementStack my computer always freezes, so even if I needed them they would not work. –  Salem Jul 11 '13 at 10:44
1  
Regarding your question, I think GRUB will always use the more recent kernel. So updating the 3.2 ones should not give you any problem at that level. –  Salem Jul 11 '13 at 10:45
    
Great, thanks for clarifying! –  Alexandr Kurilin Jul 11 '13 at 20:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.