Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am new to Ubuntu, I had an Asus laptop that came pre-installed windows 8. Last week, I installed Ubuntu on my laptop using a USB drive (dual boot). Everything works fine.

Then a day after my windows 8 system told me that the windows 8.1 is available, I clicked the upgrade button in the Windows app store. then after the upgrade of windows 8, I found out that my Ubuntu system can't be booted.

I did a research on Google, the research on google gives me the idea to use an Ubuntu live USB and go to the boot repair and use the recommended repair to fix this problem. So went to BIOS and set my Ubuntu install USB as the first booting device, then I had followed the instructions to use boot-repair.

After that a series of trouble had started, my windows 8 system can't connect to the internet any more, and in the grub menu the windows recovery is not working any more, and the short-cut key for Windows recovery is also not working.

Then I decided to delete Ubuntu from my computer, I used windows and deleted the partition that Ubuntu in. When I restart my computer the grub rescue had displayed! For that moment, I thought that's okay, because I can use a windows install USB to rewrite the MBR, and fix this problem, but the thing is when I set the USB as the booting device the light on USB went flash for just 4 sec, then it took me to the grub rescue!

My USB was working on other computers, and my USB port on my laptop still works, the BIOS can recognize the USB as a booting device, but when I select it, it will go to the grub rescue!!

Any ideas? if you need I can video the problem and upload to youtube and put the link below, so you can help me to get out this solution.

share|improve this question
    
Possible actions: try Windows DVD, check if USB stick is OK. –  Danatela Jul 10 '13 at 8:51
    
the USB is okay, also when i set all other booting device(USB, DVD, etc.) it all went to the grub rescue. –  user173987 Jul 10 '13 at 9:43
    
You said you set boot options in BIOS. Try to choose the boot drive explicitly during boot. This is often done by pressing F12 or F8 instead of DEL on the first screen (POST). –  Danatela Jul 10 '13 at 14:25
    
I also has done that as well, it doesn't works :( –  user173987 Jul 11 '13 at 5:30
    
You may also unplug HDD cable, start from DVD/USB then plug it again... But you must have SATA controller, because old IDEs do not have hot-plug capability. –  Danatela Jul 11 '13 at 10:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.