Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

When I click on Ubuntu Software Center it does nothing. Would you please help to get it working?

Also I tried update & upgrade, but no use. I tried it via terminal using software-center then it gives this error.

abdul@abdul-Lenovo-G580:~/git/Flex-Voicemail/voicemail$ software-center
2013-07-10 08:44:15,044 - - INFO - setting up proxy 'None'
2013-07-10 08:44:15,088 - softwarecenter.fixme - WARNING - logs to the root logger:         '('/usr/lib/python2.7/dist-packages/dbus/', 410, '_introspect_error_handler')'
2013-07-10 08:44:15,088 - dbus.proxies - ERROR - Introspect error on  com.ubuntu.sso:/com/ubuntu/sso/credentials: dbus.exceptions.DBusException:  org.freedesktop.DBus.Error.Spawn.ChildExited: Process /usr/lib/ubuntu-sso-client/ubuntu- sso-login exited with status 1
Traceback (most recent call last):
File "/usr/bin/software-center", line 130, in <module>
app = SoftwareCenterAppGtk3(options, args)
File "/usr/share/software-center/softwarecenter/ui/gtk3/", line 338, in  __init__
File "/usr/share/software-center/softwarecenter/ui/gtk3/session/", line 66, in __init__
self.oauth_token = helper.find_oauth_token_sync()
File "/usr/share/software-center/softwarecenter/backend/", line 141, in find_oauth_token_sync
File "/usr/share/software-center/softwarecenter/backend/login_impl/", line 75, in find_credentials
self.proxy.find_credentials(self.appname, self._get_params())
File "/usr/lib/python2.7/dist-packages/dbus/", line 70, in __call__
return self._proxy_method(*args, **keywords)
File "/usr/lib/python2.7/dist-packages/dbus/", line 145, in __call__
File "/usr/lib/python2.7/dist-packages/dbus/", line 651, in call_blocking
message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.Spawn.ChildExited: Process   /usr/lib/ubuntu-sso-client/ubuntu-sso-login exited with status 1
share|improve this question
Please run software-center from the terminal and post any errors. Thanks. – Seth Jul 10 '13 at 3:13
@Seth: i just edited my question please check. – PyGeek Jul 10 '13 at 3:20

1 Answer 1

i have installed a Zope module from some other source than the official repository, to fix this i run the following commands:

cd /usr/local/lib/python2.7/dist-packages/zope
sudo ln -s /usr/share/pyshared/zope/interface/


now it works for me. :D

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.