Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I get an error every time i try to update Firefox. I am new to the whole Ubuntu os. Any ideas?

dominicd97@DED:~$ sudo apt-get -f install
[sudo] password for dominicd97: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  firefox-globalmenu
The following packages will be upgraded:
  firefox-globalmenu
1 upgraded, 0 newly installed, 0 to remove and 72 not upgraded.
1 not fully installed or removed.
Need to get 0 B/9,086 B of archives.
After this operation, 145 kB disk space will be freed.
Do you want to continue [Y/n]? y
dpkg: dependency problems prevent configuration of firefox-globalmenu:
 firefox-globalmenu depends on firefox (= 21.0+build2-0ubuntu0.12.04.3); however
:
  Version of firefox on system is 18.0.2+build1-0ubuntu0.12.04.1.
dpkg: error processing firefox-globalmenu (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup erro
r from a previous failure.
                      Errors were encountered while processing:
 firefox-globalmenu
E: Sub-process /usr/bin/dpkg returned an error code (1)
dominicd97@DED:~$ 

It might just be my old laptop refusing to function, but i hope it can be fixed.

share|improve this question
    
Try sudo apt-get remove firefox-globalmenu then sudo apt-get update && sudo apt-get upgrade. Lastly try installing it again. –  edwin Jul 10 '13 at 0:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.