Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am a complete novice at Ubuntu and Linux systems in general. I have wanted to play around with the OS for years and finally set up a spare computer and installed Ubuntu 12.04.2. My goal is to make this machine a simple file sharing pc for my family to share all the music/videos/pictures on one machine. I have installed Samba with Samba Server Configuration.

I successfully shared the Photo/Music/Video folders on the Ubuntu pc and can access it on the Windows PC's in the house. When I set up the share options, I set access to everyone and everyone can get get access to them. No problem, so far so good.

I created a Storage folder to backup some important documents and files that I don't want the kids to have access too. When I set it up with Everyone access, I can get to the folder on my Windows 7 pc with no problems. When I set it up with specific users, I get prompted by Windows to enter user name and password; and when I enter the correct credentials, I get an error.

How can I put password protection on the shared folder so only I can get access?

share|improve this question
your samba process and your folder should be same user space. – Ankur Loriya Jul 12 '13 at 10:14

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.