Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I've read an article about installing GNOME 3.8 and tried to install it (successfully):

sudo add-apt-repository ppa:gnome3-team/gnome3
sudo apt-get update && sudo apt-get install gnome-shell ubuntu-gnome-desktop

then, I saw that I have a problem with Unity and other default Ubuntu's behaviors:

  • No Icons on the desktop.

  • launcher not always turned on when I press on winkey

  • can't select squares on the desktop (the transparent orange) with the mouse.

  • themes have changed, font, icons, etc.

  • startup image has changed, also the color of grub menu (from purple to blue).

  • other small things.

then, I decided to uninstall GNOME 3.8 and performed the steps in the article:

  • removed gnome3-team-gnome3 from the repository (in /etc/apt/sources.list.d)

  • sudo apt-get update

  • sudo apt-get remove gnome-shell ubuntu-gnome-desktop

didn't help, so i tried at least to change the themes with gnome tweaks, help a little bit but the fonts aren't as the default.

tried to install GNOME 3 from the canonical repository (the default), there I couldn't do it. It said something about dependencies.

How do I turn back the system to the previous state?

In the end I've tried to install the old gnome-shell and after a few games this is the best I've come:

maybe this will help, this is the message I've got when i tried to install the original gnome-shell:

The following information may help to resolve the situation:

The following packages have unmet dependencies:
gnome-shell : Depends: libgjs0-libmozjs185-1.0
E: Unable to correct problems, you have held broken packages.
share|improve this question

closed as off-topic by Braiam, Danatela, Sneetsher, Eric Carvalho, BuZZ-dEE May 8 '14 at 19:49

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

Did you solve this problem? If not, maybe this helps:… –  HXCaine Aug 9 '13 at 11:05

2 Answers 2

I broke my Ubuntu 13.04 with GNOME 3.8 a few days ago, too.

Then by using this remedy, I fixed my Ubuntu:

sudo apt-get install --reinstall ubuntu-desktop
share|improve this answer

looking like your Unity has crashed. try with the resetting unity.

open your terminal CTRL+ALT+T

sudo apt-get install dconf-tools
dconf reset -f /org/compiz/

Log out of your desktop session and login again.

If you'd like to reset unity icons also then do as

unity --reset-icons

then re-login into your desktop.

share|improve this answer
unfortunately not working... –  idgar Jul 9 '13 at 17:42
Any other ideas? –  idgar Jul 9 '13 at 19:30

Not the answer you're looking for? Browse other questions tagged or ask your own question.