Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After installing Firefox 4, it doesn't start.

share|improve this question

closed as too localized by Jorge Castro, Marco Ceppi Jan 29 '12 at 20:14

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
How did you install Firefox 4? –  8128 Mar 24 '11 at 6:48
    
Please try to start firefox from a terminal, and note the output, if any. Add any relevant output to your question. –  belacq Mar 26 '11 at 0:41
    
thks. its solved. there was nothing wrong. the folder .mozilla had a strange user permission. –  Amilcar Aristides Monteiro Mar 26 '11 at 7:33
    
What did you do to change permissions? chown followed by chmod? –  user17640 May 14 '11 at 18:09

1 Answer 1

This link below explains how to get firefox4 from packages from a ppa and install.

http://www.ubuntugeek.com/how-to-install-firefox-4-in-ubuntu-using-ppa.html

Just reproducing here for making it easy.

Install firefox 4 using GUI

Go to Applications > Ubuntu Software Center from the top panel go to Edit > Software Sources and click the ‘Other Software’ tab.Press ‘Add’ button and then paste the following line

ppa:mozillateam/firefox-stable

After adding the PPA you will be prompted to update your sources.

Once the update is done you can head to System > Administration > Update Manager to perform an upgrade.

Install firefox 4 using terminal

Go to Applications > Terminal in the terminal just enter the following commands

 sudo add-apt-repository ppa:mozillateam/firefox-stable

    sudo apt-get update

`sudo apt-get upgrade` (or `sudo apt-get install firefox` will upgrade current version)
share|improve this answer
    
tks. I made a new installation but it still the same. when I click to open the browser it looks like it's running than it disappear. Maybe I'm doing something wrong ;) –  Amilcar Aristides Monteiro Mar 24 '11 at 16:29
    
Did you try complete re-install? Choose firefox from Ubuntu Software Center and remove. Once completely removed, install again. Or from command line, 'sudo apt-get purge firefox' to completely remove it and 'sudo apt-get install firefox' –  Jamess Mar 24 '11 at 17:15
    
well I follow the instruction to remove firefox and I even re-start the system but after re-install it still the same. Firefox starting and then stops and gone. –  Amilcar Aristides Monteiro Mar 24 '11 at 17:59
    
solved. I change the folder permission and it works. Thanks for your help :) –  Amilcar Aristides Monteiro Mar 26 '11 at 5:34
    
seems the problem is with the folder permissions. I tried to run the profile manager and I got this IOError: [Errno 13] Permission denied: '/home/kauberdi/.mozilla/firefox.last-version' i check the folder .mozilla and the folder owner is set to 1016 - user #1016 – Amilcar Aristides Monteiro –  Amilcar Aristides Monteiro Mar 26 '11 at 20:24

Not the answer you're looking for? Browse other questions tagged or ask your own question.