Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have searched on Google, and I have completed the following steps:

  • Delete "all" activity history from the "Privacy" application.
  • Remove the file "recently-used.xbel" from ~/.local/share
  • $ nautilus -q
  • Remove the file "activity.sqlite" from ~/.local/share/zeitgeist
  • $ zeitgeist-daemon --replace &

I checked my "Recent" folder in between all of the above steps and none of them had any impact. I also tried:

  • Remove all files with "sqlite" in the name from ~/.local/share/zeitgeist (3 files:)
    • activity.sqlite
    • activity.sqlite-shm
    • activity.sqlite-wal
  • $ zeitgeist-daemon --replace &

None of the above had any impact on the contents of the "Recent" folder.

According to everything I've found, removing the file "recently-used.xbel" and restarting Nautilus should clear the "Recent" folder. Why isn't it working?

share|improve this question
1  
Guess what? You haven't Googled well enough. It's a duplicate of this question. - How to disable “recent files” folder in Nautilus? –  jokerdino Jul 9 '13 at 12:44
1  
@jokerdino: How to permanently disable recent folders? But that's not what I asked... –  Hubro Jul 9 '13 at 15:19
1  
As far as I can tell this is a perfectly valid question, it shows research effort, it's clearly worded and could well be useful for other people. Why the down votes? –  Hubro Jul 9 '13 at 23:42
    
My apologies for hastily closing. So, you don't want to disable but just simply clear it whenever you wish? It seems like clearing it is not perfect. See Nautilus 3.6: How To Clear The Recent Files List (Or Disable It). –  jokerdino Jul 10 '13 at 16:28

2 Answers 2

up vote 1 down vote accepted

Restarting Nautilus didn't work, logging out and back in (oddly) didn't work, but restarting the computer did the trick. I'm curious to find out whether this was just a fluke or if I have to reboot every time I want to clear the "Recent" folder.

share|improve this answer
    
you can also just open Recent, highlight all the files & from the r. click context menu remove them. (my current nautilus has a remove option, if not there then just choose delete instead –  doug Dec 14 '13 at 2:15

You can. Just open the recent folder, select all by Ctrl+A and clear by Shift+Delete?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.