Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can't configure my Nvidia Geforce 330M with my Dell Vostro 3700. I am using Ubuntu 10.10. It seems to be a conflict since it has two graphic cards: Intel i915 and Nvidia 330M.

It seems to be a problem without solution since september 2010, Is there a solution or workaround?

share|improve this question
    
That solution didn't helped me. I installed 64bit Ubuntu 10.10. Tried changing xorg.conf, using nvidia-current, nouveau. The command> lspci|grep -i vga shows: 00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 18) 01:00.0 VGA compatible controller: nVidia Corporation GT216 [GeForce GT 330M] (rev a2) –  Papiux Mar 24 '11 at 23:47
    
Found some notes over the internet about the "optimus" nvidia technology which enables to switch between two cards, but seems that this is handle by OS like Windows and nothing yet is developed for Linux. Some laptops bios, let you turn off one of the cards so Ubuntu can work with the other, but my Dell Vostro don't have such a choice. –  Papiux Mar 26 '11 at 0:56
add comment

2 Answers 2

Try to install bumblebee to have both the Intel and Nvidia cards working simultaneously: https://launchpad.net/~hybrid-graphics-linux

sudo apt-get install git
# type password
git clone http://github.com/MrMEEE/bumblebee.git
cd bumblebee/
sudo ./install.sh
optirun glxgears
# check the speed and compare to running:
glxgears
# If you have google-chrome installed, you can try it with/without optirun and report the FPS values on the mailing list:
optirun google-chrome http://webglsamples.googlecode.com/hg/aquarium/aquarium.html
share|improve this answer
    
Thank you @aviella for your answer. I tried some days ago Bumblebee and after installing it (before rebooting) it worked. I used "optirun64 " to run apps since my lap is 64bits, the problem comes when reboot, since it never gets into graphic mode. I analyzed (briefly and with my limited understanding) xorg.conf and there is no configuration for the laptop 1600x900 screen resolution. –  Papiux May 30 '11 at 14:11
add comment
up vote 0 down vote accepted

I tried to uninstall the Nvidia drivers unsuccesfully, so I "re-install" Ubuntu and disable Jockey (to avoid being ask again to install Nvidia drivers) and let Ubuntu just use Intel graphics driver by default. No I have 3d but sadly I have 48 nvidia cores unused.

Sad situation from Dell/Nvidia

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.