Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i'm a newbie to Linux and had install Ubuntu 12.10 dual booted with Windows8. But the ubuntu several times showed some wierd kind of errors (which I've never heard of, like it got hanged and freezed). So I decided to upgrade to 13.04.

What I did: I wanted to increase the space allocated for the disk on which ubuntu was installed, so I shrinked one disk (using Windows Partion Manager) and deleted the one in which Ubuntu(12.10) was installed.

So when I restarted it, it showed "Grub rescue" kind of error. I tried to install ubuntu (by live cd), it does not show any partition. It shows the whole hard disk as a single partition.

Moreover, when I tried to mount any of the partition (of total of 5), it says something like "cannot mount, the file system is not in fine state ... shutdown windows and try again".

When I tried to boot windows Xp (the only cd I have atm), it stuck at "Examining disk at bus 0 ..." something.

I searched and have installed Boot-Repair, whose log is http://paste.ubuntu.com/5857634/

Somebody Please guide me as I don't want all my data be erased. ps: I've about 4-5 hours to run it otherwise my brother won't let me live at peace. :/

(Sorry if the question has already been asked. I searched but couldn't find any topic with exactly the same question, and moreover I have to save the data on the disk; I can't take risks).

thanks

share|improve this question
    
Well, only one disk is seen in the log, and it is the CD. Did you enable HDD in BIOS? –  Danatela Jul 9 '13 at 8:17
    
It's already Enabled. The problem is somewhere in the Filesystem. It is not able to read it. Moreover, due to the Grub error, it's not allowing Windows to boot. –  Tarun Jul 9 '13 at 8:53
    
If it is so, Windows XP should find it. And inside Ubuntu it should be shown as /dev/sda, and your Ubuntu CD as /dev/sr0 –  Danatela Jul 9 '13 at 9:06
    
Thanks Danatela. The hard disk power cable were a bit loose and they were to be tighten. I deleted the partition in which ubuntu was previously installed, and I guess the Grub info was also purged and I am able to log into windows. –  Tarun Jul 9 '13 at 9:18
    
The problem is solved I think as I can log into windows. Now it won't be a difficult task to install ubuntu. However, if you could tell me how to merge two unallocated partitions, (one was for ubuntu and another was the reserved SWAP) that would be great. Also, is using SWAP a must? My PC specs: Dual Core 2.5GH, 2GB RAM. –  Tarun Jul 9 '13 at 9:31
show 1 more comment

1 Answer 1

Now, when your power problem is solved, you can simply reinstall Ubuntu and it will find Windows. Another solution is to restore Windows MBR.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.