Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running XP in virtualbox cause I need Photoshop and Illustrator. It works great on my 5 year old laptop which is stunning, but there's a minor annoyance when I go fullscreen.

The menu bar is in the bottom middle, and it pops up over the content. Since I use the escape buttons all the time I have no need for this to be there really, and it's really annoying when you try to change windows with the mouse and hit some random virtualbox menu item instead...

I know it's minor, and I can deal with the fact that you are probably just going to tell me to use alt+tab, but I'm just hoping there's some option I have overlooked that can turn off this bar or move it...

Thanks.

share|improve this question
up vote 70 down vote accepted

You can disable the menu bar (at least in version 4.0+, dont know about the others).

No need to shut down the virtual machine first. Go to the settings of the machine. In "General" on the "Advanced" tab you can select: "Show in Fullscreen/Seamless" and there's an option to "Show At Top Of Screen":

enter image description here

In later VirtualBox versions the setting is under "User Interface" instead of "General".

For the setting to take effect you may have to exit and return to fullscreen/seemless mode.

share|improve this answer
3  
Thanks! knew it must be somewhere. You have to shut down (not just stop) the machine to access the settings menu though. – joon Mar 24 '11 at 12:06
2  
As per tmbsteve's answer, you don't need to shut it down in the newer versions. Just go to Machine -> Settings and untick them. You can then use HostKey + Home (default host key is right-Ctrl) to bring up the context menu as and when you need it. – Polynomial Jul 17 '13 at 8:59
    
Tip: [Host key] + S = settings menu. Very useful when you have no toolbar anymore. – SgtPooki Jun 12 '14 at 18:53
2  
Does anyone know where this option has moved to in version 5? It's not available anymore in my settings. – Richard Feb 2 at 9:11
    
@richard I edited the answer to answer your question: it's under "User Interface" instead of "General". – RyanTM Mar 15 at 17:51

You can change the settings without shutting down the machine. Just go to machine > settings.

For the the menu bar settings to take effect, you will need to leave full screen mode and then re-enter it

share|improve this answer

The option to display the mini menu at the top is now (I am running version 5) in the User Interface section rather than general. I would post an image of the dialogue box - but I don't have 10 reputation points!

share|improve this answer
    
Hi Andrew, good to see that such an old question gets updated to deal with recent versions of a software! When you have gained enough reputation, come back and add a screenshot. +1 – Nephente Sep 29 '15 at 9:50
    
or you can always post a link ;-) – AlexGreg Sep 29 '15 at 9:51
    
Where in the User Interface section is it? It seems quite non-intuitive what all these options mean. – Jayen Oct 28 '15 at 6:06

Following up on Andrew Ridout's screenshot. Mini toolbar on the "User Interface" section

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.