Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Closing the lid on my dell studio 15 which is running ubuntu 10.04 freezes the screen. This is a new problem in ubuntu 10.04 which did not exist in 9.10

I have tried playing with all the settings in System->Preferences->Screensaver but nothing seems to make any difference. (please note the Power Management settings are accessible from here so I have tried those too.)

I don't need hibernate or suspend. I just want to be able to close the lid, and then open it and still have a working laptop.

Is their a settings somewhere that will make Ubuntu ignore the lid closing?

share|improve this question
1  
Please file a bug re to it freezing, also explaining if you can reproduce this problem when suspending or hibernating. –  lfaraone Aug 28 '10 at 2:47
    
the last one doesn't work if i'm working on battery power Is their a solution for this? –  ikke Dec 11 '10 at 16:49
    
I have the same problem with my laptop (Ubuntu 10.04 64bit; ATI Radeon HD 3430; HP Compaq 6730s). It is possible to move mouse pointer but it is not possible to change anything or select text on web page for example. It is reproduced sometimes. Sometimes it is reproduced even if i'm working in a browser (surely this happens with google chrome; not sure about others). The only quick solution is to activate another desktop with ctrl+alt+right and then return to previous desktop ctrl+alt+left. –  alex Dec 29 '10 at 11:40

5 Answers 5

These settings are in System -> Preferences -> Power Management.

power management

share|improve this answer
    
actually this is the same screen as you get to when clicking on the Power Management settings from within the screen saver screen. And so I have already tried changing all these settings but it still freezes –  trampster Aug 28 '10 at 2:11
2  
It interesting to note that their is actually no 'do nothing' option for when laptop lid is closed so I have it set to Blank screen like in your screen shot. –  trampster Aug 30 '10 at 23:23
up vote 2 down vote accepted

I solved this by changing to the closed source FLGRX driver.

share|improve this answer

If you disable all of hibernate, suspend and blank screen, I don't see what could make the laptop freeze... I assume you didn't install any non-default tools related to power-management?

Can you reproduce this when running from a live-CD or live-USB?

share|improve this answer
    
no non default tools and all of the stuff you mention is disabled. I will try a live cd. –  trampster Aug 29 '10 at 7:46
    
I just tried with a live cd, same problem –  trampster Sep 8 '10 at 9:44
    
You can't disable blank screen –  trampster Sep 8 '10 at 9:45

gconftool-2 --type string --set /apps/gnome-power-manager/buttons/lid_ac "nothing"

share|improve this answer
    
askubuntu.com/questions/15520/… –  badp Nov 30 '10 at 14:25

Make sure there is no SD card inserted.

ubuntuforums.org/showthread.php?t=1478787 has 120,000 views of 980 responses - it is still possible that one of the solutions will work for you.

bugs.launchpad.net/bugs/585765 is about the most useful bug report, although https://bugs.launchpad.net/bugs/528981 worked for me (mainline kernel 2.6.34 solution).

share|improve this answer
    
This is a good point to bring up, However it is not a solution for me as I have no SD cards inserted. I did spend quite some time reading and trying solutions from that thread before asking the question here. –  trampster Sep 7 '10 at 10:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.