Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have Xubuntu 13.04 on my desktop as a dual-boot system with XP. Installed it at first time two days ago and suddenly got this problem. Write my question from good old troubleproof Windows XP (long live Microsoft).

The problem:

Xubuntu boots to command line instead of GUI. It prompts for a login and a password and after I provide I get a command line instead of Xubuntu.

There are dozens of questions here about the same problem. (From 2010 it seems Ubuntu cannot fix the problem; 2010 is the oldest post I found). But all answers explain how Ubuntu may be temporarily repaired to load GUI, not Xubuntu. Mostly people suggest to type:


in command line. But is it suitable for Xubuntu? Xubuntu uses Xfce, not Gnom. What do I need to type to start GUI form command line?

Why this happens? How to start GUI again? And what to do to avoid it next time?

share|improve this question
Have you tried startx? What does it do? – mitchfish36 Jul 8 '13 at 14:51
No, I didn't. Please see my answer. – Green Jul 8 '13 at 21:13

So I managed to get GUI back without any command line typing. I did nothing, just hit Enter on Ubuntu option the next boot attempt. Just didn't let GRUB stopwatch to reach 0 and didn't use arrows in GRUB menu, just hit Enter. Very strange.

First of all, I remember when it happened. I turned on the computer and left my room to do other things. Before it I always manually selected in GRUB menu what system to load, either Xubuntu or Windows. I never let GRUB stopwatch to reach 0 and boot itself, I always hit Enter earlier. So when I came back to computer I saw the command line prompt instead of GUI.

I didn't know how to restart Xubuntu safely from the command line, so in this situation I just hit the restart button. The following boot I immediate used arrows in GRUB to go down the menu (up to Windows XP option) and then go up to select Ubuntu again. Just to stop GRUB stopwatch. Then hit Enter. But got command line again. I again reset the computer with the reset button.

This time I switched to Windows, surfed the Internet for answers, wrote this question. Found this 7 pages thread A user experienced the same problem in 2010. The main solution is on page six So I did the same.

I tried to boot again but this time I didn't use arrows. I just immediately hit Enter on Ubuntu option in GRUB. And I got GUI. Xubuntu is installed but GRUB's option is Ubuntu, not Xubuntu.

Xubuntu also fixed some crash when I entered GUI:

execution path:
   xserver-xorg-core 2:1, 13,3 - Oubuntu6
problem type:
   Xorg crashed with SIGABRT in raise()

So my conclusion is: if you want Xubuntu, immediately hit Enter in GRUB menu. Don't let stopwatch to get 0 and don't use arrows. I you want Windows, choose a Windows option using arrows and hit Enter. Isn't it ridiculous?

share|improve this answer
Ah, yeah. Xorg crashed dropping you at a TTY. – Seth Jul 8 '13 at 21:08
I'm not sure I understand your answer. Did you get the GUI back on the next boot? – Seth Jul 8 '13 at 21:17
@Seth, Yes, I got GUI back. I did nothing at all in command line, didn't type any special commands. I just hit Enter on Ubuntu option in GRUB. I didn't let GRUB to automatically start Ubuntu. – Green Jul 9 '13 at 19:03

Try to enter the following command:


startxfce4 - initialize an Xfce session

startxfce4 is a script responsible for starting an Xfce session. It runs xinit passing the file specified in the FILES subsection as an argument.



User configuration file


System wide configuration file

share|improve this answer
Welcome to AskUbuntu! This may be better as a comment. You can expand your answer, if you feel you can explain why this would work. – No Time Feb 4 '15 at 20:11
@karel no I didn't actually. Not unless it's really bad 1st attempt. I upvoted it to 0 now – No Time Feb 5 '15 at 1:17

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.