Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Just installed Ubuntu 13.04 64 and decided to run 'System Testing'(in dash type 'system testing') but it doesn't seem to be working.

It's stuck at 'Gathering information from your system':

enter image description here

How to fix it?

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

Try the following:

  • Kill all running instances of checkbox-qt: pkill checkbox-qt. Please note that a python process is also started, you have to kill that too:
$ ps fax | grep check
3796 pts/3    S+     0:00      \_ grep --color=auto check
3761 ?        Sl     0:00 python3 /usr/share/checkbox/run /usr/share/checkbox/config/checkbox-qt.ini
  • Start checkbox-qt from a terminal window. (By opening a terminal window and typing: checkbox-qt.)
  • Note the following output:
$ checkbox-qt
SYSTEM TESTING: Please enter your password. Some tests require root access to run 
properly. Your password will never be stored and will never be submitted with test 
results. PASSWORD:
  • Enter your password at the terminal and the test should continue.
share|improve this answer
    
Your solution works! THanks. But just out of curiosity why does it work from command line and not in GUI? –  Kirill Ivlev Jul 8 '13 at 9:06
    
I just have searched through Launchpad and found this bug report: Checkbox prompts for sudo password in terminal. Another report says: „gksu is deprecated for the desktop in favour of pkexec. We need to switch Checkbox over to it to avoid falling victim to bugs”. So I think since gksu is missing from Raring, it falls back to terminal. –  lgarzo Jul 8 '13 at 9:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.