Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have searched and read for months, every article I can find on this subject. All seems correct, only button presses from the remote repeat 2-4 times while controlling MythTV. I have tried repeat=0 and repeat=3 in .lircrc with no changes. It is as if .lircrc is being ignored.

The HD-PVR works. Shows up as: Bus 002 Device 006: ID 2040:4902 Hauppauge HD PVR.

These modules Are loaded:

ir_lirc_codec 12859 0

rc_core 26412 8 ir_lirc_codec,ir_mce_kbd_decoder,ir_sony_decoder,ir_jvc_decoder,ir_rc6_decoder,ir_rc5_decoder,ir_nec_decoder,ir_kbd_i2c

lirc_zilog 22513 2

lirc_dev 19204 2 ir_lirc_codec,lirc_zilog

THis all worked perfectly before upgrading to 12.04.

Any ideas will be very appreciated. Thanks.

share|improve this question

I had this problem and tried as you did to edit .lircrc, then found there was more than one instance of irexec running which caused each button to repeat. Use

ps -ef

to see what's running. I had added irexec to the startup menu based some LIRC docs I was using, but mythv did this already, I think after selecting the IR remote in the initial mythtv setup. Removed the irexec from the startup menu and problem solved.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.