Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed 13.04 a few days ago. I didn't read the install screens all that carefully and apparently picked the default partition scheme.

Now I am trying to build the Thunderbird source and I am running in to this issue:

19:43.45 /usr/bin/ld: failed to set dynamic section sizes: Memory exhausted
19:43.45 collect2: error: ld returned 1 exit status
19:43.45 make[5]: *** [libxul.so] Error 1
19:43.45 make[4]: *** [libs_tier_platform] Error 2
19:43.45 make[3]: *** [tier_platform] Error 2
19:43.45 make[2]: *** [default] Error 2
19:43.56 make[1]: *** [default] Error 2
19:43.73 make: *** [build] Error 2
19:44.21 923 compiler warnings present.

My first thought was my swap partition is too small, I only have 2gb ram and Mozilla codebase is quite large I believe.

So I do a fdisk and to my surprise there is no swap partition:

Command (m for help): p

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0009a78a

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048      499711      248832   83  Linux
/dev/sda2          501758   625141759   312320001    5  Extended
/dev/sda5          501760   625141759   312320000   83  Linux

But when I do a free it shows swap, and fstab shows that a swap is mounted:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
/dev/mapper/ubuntu--vg-root /               ext4    errors=remount-ro 0       1
# /boot was on /dev/sda1 during installation
UUID=044214de-d052-4e84-90a6-338cf5627474 /boot           ext2    defaults        0       2
/dev/mapper/ubuntu--vg-swap_1 none            swap    sw              0       0
/dev/mapper/cryptswap1 none swap sw 0 0

And /dev/mapper/ubuntu--vg-swap_1 is symlinked to /dev/dm-1.

And mount:

/dev/mapper/ubuntu--vg-root on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/cgroup type tmpfs (rw)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
none on /run/user type tmpfs (rw,noexec,nosuid,nodev,size=104857600,mode=0755)
/dev/sda1 on /boot type ext2 (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
/home/chris/.Private on /home/chris type ecryptfs (ecryptfs_check_dev_ruid,ecryptfs_cipher=aes,ecryptfs_key_bytes=16,ecryptfs_unlink_sigs,ecryptfs_sig=99409939c385d92d,ecryptfs_fnek_sig=037f9b93ee4e906e)
gvfsd-fuse on /run/user/chris/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,user=chris)

What is going on?
Do I have swap space?

share|improve this question
    
Please post your /etc/fstab and the output of mount. –  January Jul 8 '13 at 11:04
    
The fstab line for swap is posted above. When I get home I will post full fstab and mount. Thanks! –  Chris Jul 8 '13 at 14:42
    
swapon -s will list your currently active swapdevices –  thom Jul 24 '13 at 19:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.