Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have set up a Windows XP Home SP3 VM in virtualbox, installed all OK. Whenever I try to run 3D accelerated apps (games) on it/run dxdiag, it crashes with no useful information in log files (but I may provide it if needed, for now I want to know if anyone else has this problem).

Host: Athlon64 4400+ 2.4 GHz (overclock), nVidia GT520 (tried following drivers: 304,310,319,325 from ubuntu repos/xorg-edgers ppa), RAM 4 GB + zramswap enabled, kernel: Linux pf 3.9 (the same thing happened on 3.8 and 3.10 kernels)

Guest: 2D+3D acceleration (I was playing with disabling these options), 128 MB vRAM, 1 GB RAM, games tested: Team Fortress 2, Warcraft 3 - both crash the whole VM when they start.

I even tried different Virtualbox versions, different combos of kernel/drivers. Nothing worked. On vmware player, everything works but I get awful gaming experience (and high resource usage for this aging machine)

I remember the same experience from Ubuntu 12.04.2 but I wasn't using it for long because of lack of features I needed.

I'm planning on using VBoxSDL for playing games (already doing so with Age of Empires 2 which works well)

share|improve this question
    
Have you tried to increase vRAM?. It looks like a little sparse for that games. –  Javier Rivera Jul 8 '13 at 16:43
    
Warcraft 3 runs on PC with 64 MB RAM and 32 MB vRAM or so ... Team Fortress 2 could run on PC with 128 MB vRAM in the past. I can't go higher with that vRAM. Well I'm just saying that is is enough for those games since both run on a machine with the same properties in VMware player (but I can't stretch low resolution to full screen and that's why I want to use VBox) –  PLANTROON Jul 9 '13 at 17:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.