Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've enabled the hibernate option and have successfully used it multiple times before, but for some reason when I tried it a few minutes ago, it only locked the computer. Running sudo pm-hibernate seemed to do literally nothing--it asked for my password, then returned to the prompt immediately after I entered it. I think this has happened before, but I don't remember what I did to fix it (if I really did anything). I need to boot Windows, but I've got stuff open and really don't want to do a full reboot. What's going on, and how could I fix this?

share|improve this question
    
Duplicate: How to enable hibernation?. Please search AskUbuntu (top right, search bar) before opening a new question. –  edwin Jul 7 '13 at 19:49
    
@edwin I've already enabled it, and it's worked before, it just stopped working today (or some time in the past few days, between when I last successfully hibernated and now). –  Zelda64fan Jul 7 '13 at 19:54
    
Then please edit your question to specify that you made hibernate work on Raring, and that it stop working on Raring. As is, it's somewhat ambiguous. Anyway, have you updated or changed your system in any way (on which you may attribute the missing hibernate)? Also edit your question to include your PC model/specs. –  edwin Jul 7 '13 at 20:00
    
@edwin sudo pm-hibernate has always worked. "Enabling" hibernate just put a button for it in Unity's menu. All I've done recently is install whatever updates the update manager finds. –  Zelda64fan Jul 7 '13 at 20:21
add comment

2 Answers 2

One of the most common reasons of hibernate not working even after enabling by using the method xchamitha mentioned is either a missing swap partition or a missing entry for the swap partition in your /etc/fstab file. This can happen if you ever modified your swap partition by deleting, extending, recreating it. Even if you haven't, verify.

Check if you have the correct entry in your /etc/fstab by opening a terminal(Ctrl+Alt+t) and then type:

sudo blkid

this will give you an output such this(this is mine, your's will have different number of partitions with different UUID's):

/dev/sda1: UUID="E8EE-D6B7" TYPE="vfat" 
/dev/sda2: LABEL="Windows and Components" UUID="CAE8DFDDE8DFC63B" TYPE="ntfs" 
/dev/sda4: LABEL="Peripherals and Support" UUID="01CEB0A39FEAB500" TYPE="ntfs" 
/dev/sda5: UUID="dcce3bed-77bd-497a-af91-6de6a1a68617" TYPE="ext4" 
/dev/sda6: UUID="85b5c13d-93ed-487b-a4b2-9004a1fd27b0" TYPE="ext4" 
/dev/sda7: UUID="7301ea57-3526-4336-b541-1e8a0422e402" TYPE="ext4" 
/dev/sda8: UUID="b23adddf-2164-46ab-aa3a-bd8d83158d22" TYPE="swap" 

the last entry is of the swap partition. Note the UUID of the swap partition(it is b23adddf-2164-46ab-aa3a-bd8d83158d22 for mine). If you don't have such a line, you don't have a swap partition and you will need to create one using either the GUI method or the command-line method.

Next, check if there is a line in your /etc/fstab file similar to this:

UUID=b23adddf-2164-46ab-aa3a-bd8d83158d22 none            swap    sw              0       0

This line tells the kernel to mount the swap partition on boot, which is important for hibernation to be available. The entries here are separated by space(s)(the number of spaces does not matter, you should have at least one space between two entries).

Once you have completed this, reboot your machine and you should have an entry to hibernate.

share|improve this answer
    
Did exactly that but still can't hibernate. I increased my swap size, added the new UUID into the /etc/fstab but still can't hibernate. –  user240955 Jan 28 at 14:46
    
@user240955: What do you get when you type sudo pm-hibernate on a terminal? –  i08in Jan 28 at 17:09
add comment

Try following, this blogpost on how to enable hibernate in ubuntu 13.04. http://xchamitha.blogspot.co.uk/2013/07/enabling-hybernate-in-ubuntu-1304.html.

To summarise:

Enabling Hybernate in Ubuntu 13.04

Open a terminal CTRL+ALT+T and type,

sudo gedit /var/lib/polkit-1/localauthority/50-local.d/hibernate.pkla

Paste the following and save the file.

[Re-enable Hibernate]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

Reboot your computer.

share|improve this answer
    
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.