Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've used the universal USB installer to put ubuntu-12.04.2-desktop-amd64.iso on my USB drive.

It correctly boots from the USB, but the installation seems to stop almost right when it starts.

It's the first time I'm installing a different OS than Windows, so I don't exactly know what it doing, but I'd think the installation is initializing.

It stops on:

(last two lines)

0.003749] mce: CPU supports 7 MCE banks
0.004985 ACPI: Core revision 20120320

My configuration is:

  • RAM: 8GB
  • Processor: AMD A10-5800K Black Edition
  • Motherboard: MSI FM2-A75IA-E53
  • SSD 128GB
  • HDD 2TB
share|improve this question
    
Probably a Firmware bug. Try updating your Mainboard firmware (BIOS), and if that doesn't help, try the latest Ubuntu version, maybe there's a quirk (aka workaround) available meanwhile. –  soulsource Jul 7 '13 at 14:39
    
You can also try to disable ACPI when booting, but if you don't get it running after installation, you might not be able to use power management features. wiki.ubuntu.com/DebuggingACPI –  soulsource Jul 7 '13 at 14:50
    
Thank you, it was indeed a Firmware issue. It was quite a fight (finding the correct image to make a bootable USB), but I've updated the BIOS to the latest version and all installation issues with the different versions I tried (latest version, 12.04, XBMCbuntu) are solved. –  ElConejito Jul 9 '13 at 22:27
    
I'll copy-paste my comment in an answer, so you can accept it. –  soulsource Jul 10 '13 at 8:16

2 Answers 2

up vote 1 down vote accepted

Problems with ACPI can be caused by Firmware bugs. I'd recommend to try to update the Mainboard firmware (BIOS), and if that doesn't help, try to use the latest Ubuntu version. If the Linux developers get to know about buggy firmware, they often implement so called quirks, which should enable Linux to run on it nevertheless, and maybe a suitable quirk for your hardware is already included in the latest Ubuntu.

You can also try to disable ACPI when booting, but if you don't get it running after installation, you might not be able to use power management features. To disable ACPI, you can pass the ACPI=off parameter to the kernel. A temporary way to do this is to press "e" in the GRUB menu to edit the current selection, then add the paramter in the appropriate line (the one that also has quiet written in it) and then press CTRL+x to boot. For a permanent setting after installation, edit /etc/defaults/grub. For more details see http://wiki.ubuntu.com/DebuggingACPI

share|improve this answer

Make sure that you have the partition set up correctly, and that there is space for it. I got this same error before, when trying to install on a partition with not enough space allocated. If you still get this error, or you have enough space in the partition/hard drive, I would suggest using Ubuntu Desktop to install, if you want Ubuntu on your main hard drive. It is safer and easier to set up.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.