Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

this involves the game Hotline Miami which I bought from the Humble Bundle 8 a while ago.

After installing it and clicking the executable nothing happened so I ran it from the terminal and got this error:

/opt/hotline-miami/hotline_launcher: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory

But I do appear to have libGL.so.1 installed according to the locate command which gives me this:

/usr/lib/i386-linux-gnu/mesa/libGL.so.1
/usr/lib/i386-linux-gnu/mesa/libGL.so.1.2.0
/usr/lib/i386-linux-gnu/primus/libGL.so.1
/usr/lib/nvidia-current-updates/libGL.so.1
/usr/lib/x86_64-linux-gnu/mesa/libGL.so.1
/usr/lib/x86_64-linux-gnu/mesa/libGL.so.1.2.0
/usr/lib/x86_64-linux-gnu/primus/libGL.so.1
/usr/lib32/nvidia-current-updates/libGL.so.1

Any idea on what is causing this problem? I wasn't able to find any solution online.

Computer is an Acer 4830TG running Ubuntu 12.04 (This game worked on 12.10 perfectly fine before I had decided to switch to 12.04)

share|improve this question
    
askubuntu.com/questions/285642/… –  Qasim Jul 7 '13 at 12:56
    
@Qasim I tried your answer in that link to the question you posted but I still get the error I posted above. –  ThatsNotMyName Jul 7 '13 at 13:14
    
sudo ln -s /usr/lib/i386-linux-gnu/mesa/libGL.so.1 /lib32/ && sudo ln -s /usr/lib/x86_64-linux-gnu/mesa/libGL.so.1 /lib64/ && sudo ldconfig -v –  Qasim Jul 7 '13 at 13:21
    
Ok I tried it again but replaced it with the 64 bit libraries but now I get error while loading shared libraries: libGL.so.1: wrong ELF class: ELFCLASS64, I looked up the solution for it but that didn't work and i still get the same error. –  ThatsNotMyName Jul 7 '13 at 13:34
add comment

1 Answer 1

up vote 0 down vote accepted

It seems that if I uninstall ia32-libs and the packages that depended on it the game will run though there is the issue of no sound currently.

share|improve this answer
    
Could you add instructions on which specific libraries and how exactly you removed them to your answer in order to help future users? Thanks. –  Kevin Bowen Jul 8 '13 at 0:52
    
ok, I added which libraries I had removed. –  ThatsNotMyName Jul 8 '13 at 4:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.