Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Some of the software I want to use has a dependency on development headers of curl library. I did apt-cache search libcurl and see that libcurl4-gnutls-dev and libcurl4-openssl-dev packages provide the necessary development headers.

However, when I run sudo apt-get install libcurl4-gnutls-dev I get the following error:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libcurl4-gnutls-dev : Depends: libkrb5-dev but it is not going to be installed or
                                hurd but it is not installable
E: Broken packages

Googling for this did not prove helpful.

I am running Ubuntu 10.10. uname -a on my system gives the following output:

Linux skynet 2.6.35-22-generic #33-Ubuntu SMP Sun Sep 19 20:32:27 UTC 2010 x86_64 GNU/Linux

Any clue on how to fix the broken package error?

Output of sudo apt-get update

Get:1 http://extras.ubuntu.com maverick Release.gpg [72B]                                      
Ign http://extras.ubuntu.com/ubuntu/ maverick/main Translation-en                              
Get:2 http://linux.dropbox.com maverick Release.gpg [489B]           
Ign http://linux.dropbox.com/ubuntu/ maverick/main Translation-en             
Ign http://linux.dropbox.com/ubuntu/ maverick/main Translation-en_IN
Ign http://extras.ubuntu.com/ubuntu/ maverick/main Translation-en_IN
Get:3 http://extras.ubuntu.com maverick Release [9,762B]
Get:4 http://linux.dropbox.com maverick Release [2,605B]
Get:5 http://extras.ubuntu.com maverick/main Sources [668B]                          
Get:6 http://linux.dropbox.com maverick/main amd64 Packages [772B]                        
Hit http://in.archive.ubuntu.com maverick Release.gpg                      
Get:7 http://extras.ubuntu.com maverick/main amd64 Packages [700B]
Ign http://in.archive.ubuntu.com/ubuntu/ maverick/main Translation-en
Ign http://in.archive.ubuntu.com/ubuntu/ maverick/main Translation-en_IN                                                                                                                                       
Ign http://in.archive.ubuntu.com/ubuntu/ maverick/multiverse Translation-en                                                                                                                                    
Ign http://in.archive.ubuntu.com/ubuntu/ maverick/multiverse Translation-en_IN
Ign http://in.archive.ubuntu.com/ubuntu/ maverick/restricted Translation-en
Ign http://in.archive.ubuntu.com/ubuntu/ maverick/restricted Translation-en_IN
Ign http://in.archive.ubuntu.com/ubuntu/ maverick/universe Translation-en
Ign http://in.archive.ubuntu.com/ubuntu/ maverick/universe Translation-en_IN
Hit http://in.archive.ubuntu.com maverick Release       
Hit http://in.archive.ubuntu.com maverick/main Sources
Hit http://in.archive.ubuntu.com maverick/restricted Sources
Hit http://in.archive.ubuntu.com maverick/universe Sources
Hit http://in.archive.ubuntu.com maverick/multiverse Sources
Hit http://in.archive.ubuntu.com maverick/main amd64 Packages
Hit http://in.archive.ubuntu.com maverick/restricted amd64 Packages
Hit http://in.archive.ubuntu.com maverick/universe amd64 Packages
Hit http://in.archive.ubuntu.com maverick/multiverse amd64 Packages
Fetched 15.1kB in 1min 16s (197B/s)
Reading package lists... Done

Output of sudo aptitude install libcurl4-gnutls-dev

The following NEW packages will be installed:
  comerr-dev{a} krb5-multidev{ab} libcurl4-gnutls-dev libgcrypt11-dev{a} libgnutls-dev{a} libgpg-error-dev{a} libgssrpc4{a} libidn11-dev{a} libkadm5clnt-mit7{a} libkadm5srv-mit7{a} libkdb5-4{a} 
  libkrb5-dev{a} libldap2-dev{a} libtasn1-3-dev{a} 
0 packages upgraded, 14 newly installed, 0 to remove and 0 not upgraded.
Need to get 4,436kB of archives. After unpacking 13.2MB will be used.
The following packages have unmet dependencies:
  krb5-multidev: Depends: libkrb5-3 (= 1.8.1+dfsg-5) but 1.8.1+dfsg-5ubuntu0.1 is installed.
                 Depends: libk5crypto3 (= 1.8.1+dfsg-5) but 1.8.1+dfsg-5ubuntu0.1 is installed.
                 Depends: libgssapi-krb5-2 (= 1.8.1+dfsg-5) but 1.8.1+dfsg-5ubuntu0.1 is installed.
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     krb5-multidev [Not Installed]                      
2)     libcurl4-gnutls-dev [Not Installed]                
3)     libkrb5-dev [Not Installed]                        



Accept this solution? [Y/n/q/?] Y 
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
share|improve this question
    
Can you please post the output of sudo apt-get update and sudo aptitude install libcurl4-gnutls-dev? –  arrange Mar 23 '11 at 19:47
add comment

1 Answer 1

up vote 3 down vote accepted

Try allowing the maverick-security repository. Then update the cache

sudo apt-get update

and try installing again.

share|improve this answer
    
Great. That worked!! –  ardsrk Mar 23 '11 at 20:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.