Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to configure an old laptop, and this is driving me up the wall. I have spent at least ten hours trying solutions to no avail.

I initally installed mesa 7.11, which did not work. I currently have mesa 8 along with the Xorg Edgers mesa-legacy 7.11 drivers.

sudo lshw -c video returns:

display UNCLAIMED     
       description: VGA compatible controller
       product: VT8375 [ProSavage8 KM266/KL266]
       vendor: S3 Inc.
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 00
       width: 32 bits
       clock: 66MHz
       capabilities: vga_controller bus_master cap_list
       configuration: latency=64 maxlatency=255 mingnt=4

My current xorg.conf looks like this:

Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen         "Default Screen"
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
    ModulePath   "/usr/lib/xorg/modules"
    FontPath     "/usr/share/fonts/X11/misc"
    FontPath     "/usr/share/fonts/X11/cyrillic"
    FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath     "/usr/share/fonts/X11/Type1"
    FontPath     "/usr/share/fonts/X11/100dpi"
    FontPath     "/usr/share/fonts/X11/75dpi"
    FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    FontPath     "built-ins"
EndSection

Section "Module"
    Load  "record"
    Load  "dbe"
    Load  "extmod"
EndSection

Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"
EndSection

Section "InputDevice"
    Identifier  "Mouse0"
    Driver      "mouse"
    Option      "Protocol" "auto"
    Option      "Device" "/dev/input/mice"
    Option      "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
    Identifier   "Monitor Generic"
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"
EndSection

Section "Device"
    Identifier  "Card0"
    Driver      "savage"
EndSection

Section "Screen"
    Identifier "Default Screen"
    Device     "Card0"
    Monitor    "Monitor Generic"
    SubSection "Display"
    Depth 32
    EndSubSection
EndSection

I have tried many different Xorg options, downgrades of driver packages and the like. The only two outcomes I have been able to achieve are:

NoAccel in xorg.conf: VGA driver is used, and GLXgears gets ~5 FPS. Not an optimal outcome.

Anything else: Any OpenGL application crashes on startup with the error "Wait returned -16" and the system completely locks up, necessitating power cycling.

Well, there is a third outcome that I noticed: enabling ShadowFB caused artifacts all over the screen and made the bottom half of the screen unusable.

Any help is much appreciated. I have seen that this issue has been raised before on several websites while trying to diagnose this problem, but nothing suggested has worked.

share|improve this question
add comment

1 Answer

I managed to fix it...Kind of. It still says display unclaimed and GLXinfo crashes, but I can run OpenGL applications.

I added this to Xorg.conf

Section "Device"
    Identifier  "Card0"
    Driver      "savage"    
    Option      "AGPMode"   "4"
    Option      "HWCursor"  "True"
    Option      "UseBIOS"   "False"
    Option      "ShadowStatus"  "False"
    Option      "AGPSize" "16"
    Option      "DmaMode" "Any"
    Option      "DmaType" "AGP" 
    Option      "BusType" "AGP" 
    Option      "ForceInit" "Yes" 
    VideoRam    32768 
EndSection

Section "dri"
    Mode         0666
EndSection 

I also messed around with settings in DRIconf. I still don't understand what the problem was as the savage driver was being loaded correctly, DRI rendering was active, and I could find no errors in any logs.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.