Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having troubles with a simple SSH Connection at home.

I installed openSSH on an Ubuntu Server. I generated the rsa and dsa but this ssh connection stops while expecting a MSG packaget that I don't understand. I previuosly installed no-ip and linked it to my network but I think this is not the problem.

OpenSSH_6.1p1 Debian-4, OpenSSL 1.0.1c 10 May 2012
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: Connecting to blue-house.servebeer.com [87.221.76.172] port 22.
debug1: Connection established.
debug1: identity file /home/miguel/.ssh/id_rsa type -1
debug1: identity file /home/miguel/.ssh/id_rsa-cert type -1
debug1: identity file /home/miguel/.ssh/id_dsa type -1
debug1: identity file /home/miguel/.ssh/id_dsa-cert type -1
debug1: identity file /home/miguel/.ssh/id_ecdsa type -1
debug1: identity file /home/miguel/.ssh/id_ecdsa-cert type -1
debug1: Remote protocol version 2.0, remote software version dropbear_0.36
debug1: no match: dropbear_0.36
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_6.1p1 Debian-4
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client 3des-cbc hmac-md5 none
debug1: kex: client->server 3des-cbc hmac-md5 none
debug1: sending SSH2_MSG_KEXDH_INIT
debug1: expecting SSH2_MSG_KEXDH_REPLY
Read from socket failed: Connection reset by peer

UPDATE 1: There is something related with dropbear_o.36 that is very old in my router.

Here a post an image that shows that I have no problems to connect straight with my IP, but with a DNS (I have set up 2, no-ip and freedns, but got the same result)

screenshot

I think I can't update my router firmware anymore...What should I do?

share|improve this question
    
I did it. Thanks a lot. –  wwglobers Jul 7 '13 at 11:06
    
Are you sure, that your Ubuntu machine is answering, and not your router? –  soulsource Jul 7 '13 at 11:30
add comment

1 Answer

This solved my similar problem:

apt-get install putty-tools
plink admin@routerip
...
Server version: SSH-2.0-dropbear_0.46
Using SSH protocol version 2
We claim version: SSH-2.0-PuTTY_Local:_Aug_11_2013_21:26:51
Using Diffie-Hellman with standard group "group1"
Doing Diffie-Hellman key exchange with hash SHA-1
Host key fingerprint is:
ssh-rsa 1040 d6:8f:96:ec:73:70:67:33:70:a7:52:a6:8a:2f:56:14
Initialised triple-DES CBC client->server encryption
Initialised HMAC-SHA1 client->server MAC algorithm
Initialised triple-DES CBC server->client encryption
Initialised HMAC-SHA1 server->client MAC algorithm
Using username "admin".
admin@10.1.0.150's password: 
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.