Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I type in this command:

sudo add-apt-repository ppa:webupd8team/java

The system echos something along the lines of "Can't access lanchpad.net PPA, please check your internet connection"

My Internet connection is working fine, and just to see if it would help I reset my modem and router. Still, no luck.

I have also tried to add this PPA via Ubuntu Software Center but that has not changed anything.

How do I get past this error? At this point I'm considering totally re-installing Ubuntu 13.04

share|improve this question
3  
Are you behind a proxy? Do you get errors when you do sudo apt-get update? –  Alaa Ali Jul 6 '13 at 14:41
    
Try add this sudo add-apt-repository ppa:nilarimogard/webupd8. It works for me. –  Shaharil Ahmad Jul 6 '13 at 16:10
    
If you are behind a proxy, try using sudo -E add-apt-repository ppa:webupd8team/java to get the environment settings. –  DaShaun May 15 at 20:26

2 Answers 2

try adding the source manually into /etc/apt/sources.list or do it through the software manager add sources. the option explained https://launchpad.net/~webupd8team/+archive/java in technical details about this ppa

share|improve this answer

If you are behind a proxy set the https_proxy environmental variable to your custom setting, for example:

export https_proxy=http://myproxy.domain.net:8080/

Then run sudo add-apt-repository with the -E flag to pass the environmental variables:

sudo -E add-apt-repository ppa:webupd8team/java 

For some reason add-apt-repository doesn't use the proxy settings for apt.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.