Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Wifi has worked great, but here in Vientiane having some problems. Chain of coffee houses provide wifi, each with different name / password. In some can log in, in others cannot. Microsoft and Mac users are successful.

The only thing I can see is that login is successful when the password is 8 characters long, and fails when the password is 9 characters long.

The situation is consistent.

share|improve this question
    
is it with all passwords more than 9 characters such as at other hotspots? Also what security are they using? This should be found in the network manager. –  namingFailed Jul 6 '13 at 9:52
    
@namingFailed - the chain uses only 8 and 9 character passwords so far. the 9 character passwords fail. the security is "WPA/WPA2". btw, there are really two chains, with exactly the same symptoms, so I feel this is not a one-off situation. –  cc young Jul 6 '13 at 9:59
    
sorry. I meant if possible have you tried using any other hotspot with a password of more than 8 characters rather at other chains. This is odd so next step is to see if the problem is with the network manager. use wpa-supplicant to log in: make a file with this content: network={ ssid="name_of_hotspot" psk="password" } and then use wpasupplicant: sudo wpa_supplicant -B -Dwext -iwlan0 -c/path/to/file then sudo dhclient wlan0 –  namingFailed Jul 6 '13 at 10:20
    
@namingFailed - will do. will take a day to get back, but will do so. thanks. –  cc young Jul 6 '13 at 10:29
    
@namingFailed - got error:ine 1: unknown global field 'network={ ssid="JomaPT" psk="jomapttwo" }'. Line 1: Invalid configuration line 'network={ ssid="JomaPT" psk="jomapttwo" }'. Failed to read or parse configuration '/data/tnt/server/wpa.network'. –  cc young Jul 9 '13 at 5:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.