Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been trying to look for ways to overclock my rather old cpu, AMD Turion 64 x2 Tl-56 1.8ghz dual core. My Acer Aspire 5100 series bios does not give me the option to overclock. After referring to this question and this thread I found using google, I came to the conclusion the only utility that supports AMD's k8 processor family was cpupowerd. I downloaded the code here, compiled it with

make && sudo make install

loaded the msr kernel module with

sudo modprobe msr

and ran it with

sudo ./cpupowerd --freq "0|1900"

which returned the following message:

cpupowerd 0.2.1 written by Markus Strobl.
WARNING: This program could cause damage to your Hardware!
Frequency 1900 MHz not available!

I then did

sudo ./cpupowerd -s

which returned

cpupowerd 0.2.1 written by Markus Strobl.
WARNING: This program could cause damage to your Hardware!
Vendor                      : AMD
Family                      : K8
Model                       : 4
  Mastercpuid               : 0
    Affected cpuids         : 0 1
    Current voltage (VID)   : 1.1000 V (18)
    Current frequency (FID) : 1800 MHz (10)
    Supported frequencies   : 800 1600 1800 MHz

It doesn't want to set the frequency to something other that what's on the supported frequencies list. Is there any way for more to override it or alter it? Alternatively, is there another utility I could use to overclock my cpu on Ubuntu?

I am able to use cpupowerd as is to set the frequency to 800mhz and 1.6ghz.

share|improve this question
    
Overclocking the AMD turion i dont think this is supported with ubuntu. –  sean fell Jul 5 '13 at 23:25
    
I think you have to use a certain multiples when setting clock speed. Like how bits come in multiples of 8 (8,32,64 etc.) –  user2201182 Nov 17 '13 at 19:32

1 Answer 1

up vote 0 down vote accepted

Supported frequencies : 800 1600 1800 MHz

This is telling you what frequencies the CPU core allows. If you don't use these, cpupowerd will refuse to change the frequencies. Try using instead:

sudo ./cpupowerd --freq "0|1800"
sudo ./cpupowerd --freq "0|1600"
sudo ./cpupowerd --freq "0|800"

Also, remember that not all cores allow overclocking, which is what I suspect it's happening.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.