Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've created a custom layout by creating a layout in /usr/share/X11/xkb/symbols/chn.

I also added the XML information to /usr/share/X11/xkb/rules/evdev.xml.

I can choose the layout using the layout setting menus, but if I preview the keyboard layout, it just shows a standard US English layout, and as soon as I try to add the layout I get the following error message:

Error activating XKB configuration.

There can be various reasons for that.

If you report this situation as a bug, include the results of

• xprop -root | grep XKB

• gsettings get org.gnome.libgnomekbd.keyboard model

• gsettings get org.gnome.libgnomekbd.keyboard layouts

• gsettings get org.gnome.libgnomekbd.keyboard options

As far as I can tell, everything in my entries in the layout file and evdev.xml is correct. Why does XKB not understand the custom map? Is there some new configuration policy for Ubuntu 13.04? This is unlike any other custom keyboard question I've seen in that all the configuration seems to have work, but I cannot select the custom layout for use, and it seems not to detect the modifications to the layout.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.