Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm on ubuntu 13.04 and I run into similar situation and don't know how to resolve the dependencies issues. Anyone can help?

mk@MS7549:~$ sudo apt-get install phablet-tools
[sudo] password for mk: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 phablet-tools : Depends: python-configobj but it is not installable
                 Depends: python-launchpadlib but it is not installable
                 Depends: python-requests but it is not installable
E: Unable to correct problems, you have held broken packages.

Then I tried to install those 3 python packages but they are NOT available. What do I need to do now?

mk@MS7549:~$ sudo apt-get install python-configobj
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package python-configobj is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'python-configobj' has no installation candidate

mk@MS7549:~$ sudo apt-get install python-launchpadlib
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package python-launchpadlib is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'python-launchpadlib' has no installation candidate

mk@MS7549:~$ sudo apt-get install python-requests
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package python-requests is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'python-requests' has no installation candidate
share|improve this question
    
What other sources (universe, multiverse, partner) do you have enabled? Are you up-to-date? –  david6 Jul 5 '13 at 23:01
add comment

2 Answers

This works for me with Ubuntu 13.04 64-bit.

Did you do first add the PPA?

from: https://wiki.ubuntu.com/Touch/Install

sudo add-apt-repository ppa:phablet-team/tools

sudo apt-get update

sudo apt-get install phablet-tools android-tools-adb android-tools-fastboot

share|improve this answer
    
yes. I did both sudo add-apt-repository ppa:phablet-team/tools and sudo apt-get update. However, when it comes to sudo apt-get install phablet-tools, I have problems. –  Manny Kung Jul 5 '13 at 22:37
    
Note that I did sudo apt-get install android-tools-adb and sudo apt-get install android-tools-fastboot separately and they are fine. I only have issues with phablet-tools. Any insights on why? –  Manny Kung Jul 5 '13 at 22:40
add comment

I had the very same problem for 13.10. What I did was to change the the "Download From: " server in the "Software & Update". It was set on "Server for Sweden" (Since I am from Sweden) and I switched to Download from "Main server" and suddenly everything started working. So either the Swedish server was out of date or something had gone awry in my old updates that now works.

Hope it helps!

Edit: And yes I had added the ppa and made an apt-get update

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.