Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

today I've updated openssl and libssl (automatic update). After reboot I can't login with any user (even with Guest or new one) into X. I've tried with installing gdm, gnome-session-fallback - no luck.

On login screen (no matter if it's lightdm or gdm) I type password, it tries to login, then screen goes black and returns to login screen.

I've found somewhere solution with Xauthority and xsession-errors, but in .xsession-errors I don't have anything but two lines:

Script for cjkv started at run_im. Script for default starter at run_im.

I'm using Linux for about 10 years, but I can't find anything in /var/log that can point me to solution. Reinstalling Ubuntu IS NOT A SOLUTION for me.

Someone can help me?

share|improve this question

4 Answers 4

Solution from OP:


I've found the solution. Somehow automatic updates installed libssl1 for amd64 AND i386.

I've noticed this after I've tried to ssh to another pc - ssh just quits without any message. I've reinstalled the amd64 version of libssl and now everything works.

share|improve this answer
    
same thing happens with me with 13.04 but i have to re-install it because i am very new to ubuntu. can you please explain how you resolve it in step by step. because i don't how to use ubuntu after you came on black command screen (alt+f2). may be it is helpful for others and me (next time). thanks –  netsmertia Jul 8 '13 at 18:57

I just had the same symptoms on my 13.04 machine. I was able to log in remotely and run the following:

sudo apt-get update && sudo apt-get upgrade

This resolved the problem for me - did not even have to reset.

share|improve this answer
    
not need to do remotely - I switch over desktop to terminal with ALT+CTRL+F1 and there I could login and did the update –  laplasz Dec 8 '13 at 20:03

In my case, the problem was simply a bad .Xauthority and/or .xsession files. You can test for this by seeing if another user on the machine can log in successfully. If so, the problem is something about you.

The solution is to delete those files out of my home directory. After this, a Unity login worked fine.

share|improve this answer

I had the same problem with Ubuntu 14.04. Guest user could login, but not me.

I'd deleted .Xauthority for my user and reboot. It gives some problems alerts during the boot but it worked fine.

Ctrl+Alt+F1, login in shell, and then rm /home/<user>/.Xauthority. Then sudo reboot

Thanks davmp

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.