Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu 13.04 (64 bit). Unfortunately it seems that my favourite window switcher in Compiz is missing in 13.04?

Does anyone know if:

  1. this is a bug.
  2. there is a way to get it back (maybe a plugin)
  3. this is because I used the software center to install compiz which results in an out of date version?

Also, the shortcut to trigger the expo is super-s, however this only works sometimes, such as after a reboot. Right now, I am having to manually click this icon to have the same effect.

enter image description here

Is there a way I can just map that icon to the keyboad shortcuts (workaround)?

Also, the 'commands' feature appears to be missing from compiz as well (it used to be by 'general'. This is 'ok' as I have managed to set everything from the normal keyboard shortcuts menu for now as shown here: enter image description here

Summary:

  1. How can I install the compiz window switcher in ubuntu 13.04.
  2. How do I get the 'expo' feature to always trigger when I press cntrl-s

Update:

It appears that disabling the launcher key (super) also disables the expo functionality (super-s). Is there any way to disable the launcher without disabling the 'expo' functionality.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

The absence of workspace switcher is not a bug, but a design decision. To reenable it, simply right click on your desktop and choose Change Desktop Background. Then hit the Behavior tab and enable the workspace switcher.

enter image description here

As for the keyboard shortcuts to open the Dash and Expo, these can be simply changed in the CompizConfig Settings Manager. For the Dash, click on Ubuntu Unity Plugin, then change the shortcut at the top:

enter image description here

For Expo, click on Expo and change the Expo key shortcut:

enter image description here

Finally, as rrosa pointed out, you need to make sure you have installed the extra Compiz plugins to use Commands in the CompizConfig Settings Manager.

share|improve this answer

i did this and got the switchers back:

sudo apt-get install compiz-plugins-extra compiz-plugins compiz-gnome

salú

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.