Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm very new to both Ubuntu and Maven, so apologies if any part of my question is either obvious or confusing.

I am running Ubuntu 13.04 in Oracle's Virtual Box. I have set up a new user (hduser) with sudo permissions and downloaded Apache Hadoop and extracted it onto the system, with everything going swimmingly. I then downloaded the binary source tarball of Apache Flume.

The instructions I had were to unzip the file, navigate to the unzipped directory and run the command "mvn package". When I try this (or mvn install, or install skip tests), I get this error immediately:

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-remote-resources- 
plugin:1.1:process (default) on project flume-parent: Error finding remote resources 
manifests: /home/hduser/flume/target/maven-shared-archive-resources/META-INF/NOTICE 
(No such file or directory) -> [Help 1]

If I run "mvn -version", I get:

Apache Maven 3.0.4
Maven home: /usr/share/maven
Java version: 1.7.0_25, vendor: Oracle Corporation
Java home: /usr/lib/jvm/jdk1.7.0/jre
Default locale: en_GB, platform encoding: UTF-8
OS name: "linux", version: "3.8.0-19-generic", arch: "amd64", family: "unix"

The error message appears basic enough - that Maven is searching for a directory that should exist in the "flume" folder on the "hduser" directory, but it cannot find it.

However, I'm totally confused about how to fix this problem. I have tried using the Flume source download as well as the binary file, but the problem appears to be with Maven, not the Flume download.

The Maven I got by simply doing an apt-get update then apt-get install maven. Have I made some simple error? Could anybody tell me how to fix this? Thanks

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.