Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using ubuntu 12.04 and already have python 2.7 installed. I need python 3.3.2 to be installed for some course. So i am trying to do that. I found this ubuntu link

Install Python 3.3.2 on Ubuntu

I tried to do the same. It was succesful but it's not running python 3.3.2 but running python 3.2.3. How should i install python 3.3.2?

share|improve this question
    
I tried to do sudo apt-get install python3.3. I get the following error.The following packages have unmet dependencies: libh323plus-dev : Depends: libpt2.4.5-dev but it is not going to be installed Conflicts: libopenh323-dev but 1.18.0.dfsg-10build2 is to be installed libopenh323-1.18.0 : Conflicts: libopenh323-1.18.0-develop but 1.18.0.dfsg-10build2 is to be installed libopenh323-1.18.0-develop : Conflicts: libopenh323-1.18.0 but 1.18.0.dfsg-10build2 is to be installed Conflicts: libopenh323-1.18.0-ptrace E: Unable to correct problems, you have held broken packages. –  Talasila Jul 5 '13 at 6:41

1 Answer 1

up vote 6 down vote accepted

I'd try

pip install python3.3.2 --user

or

wget http://python.org/ftp/python/3.3.2/Python-3.3.2.tar.bz2
tar xf Python-3.3.2.tar.bz2
cd Python-3.3.2
./configure --prefix=/usr/local
make && sudo make altinstall

In both cases You should then try to start it with

$ python3.3
share|improve this answer
    
Thankyou. The second one worked perfectly. –  Talasila Jul 5 '13 at 8:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.