Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have most of my disk space in an ext4 partition which I automountt on startup through fstab. The corresponding line in fstabis this one:

/dev/sda9 /media/rest    ext4  users,user    0  0

Now I'm trying to install a game through Steam and I want the data folder to be stored in said partition, but when I try to select a folder in it I get the error:

New Steam library folder must be on a filesystem mounted with execute permissions

So I need that partition to have execute permissions. I'm guessing modifying the line in fstab to this might do the trick:

/dev/sda9 /media/rest    ext4  users,user,exec    0  0

but I'm not really sure and I don't want to mess up my system. Is this the correct solution for the mentioned issue?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

The defaults option in fstab will give you what you want. As per mount ,

man mount

defaults
          Use default options: rw, suid, dev, exec, auto, nouser, and async.

So a line like

/dev/sda9 /media/rest    ext4  defaults    0  0

should be OK.

share|improve this answer
    
This fixed it for me! Thanks –  SirSid Oct 8 '13 at 15:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.