Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ever since upgrading to 13.04 I have been experiencing a rather weird phenomenon. At the office, we primarily use Ethernet, but there is also a WiFi network in the building (lets call it wifix). If I want to use the Ethernet rather than wifix I must make sure my laptop has booted with wireless disabled; if wireless is enabled it will connect to wifix during bootup, and the Ethernet will somehow not work. Even if I then disable wireless after booting. So to get Ethernet to work, I must disable wireless, and reboot my machine. This means I must remember to disable wireless each time I shut down my laptop. Or else I must reboot just to get the freaking Ethernet to work.

There must be a way to fix this, but how?

share|improve this question
add comment

1 Answer 1

Try executing this command

echo on | sudo tee /sys/class/net/eth0/device/power/control

it usually solves all ethernet-related issues

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.