Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed pysdm through this article to auto-mount my ntfs partitions.

My drive structure looks like this:

jatin@jatin-ubuntu:/media$ df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/sda8              18G   12G  5.5G  68% /
none                  1.5G  344K  1.5G   1% /dev
none                  1.5G  216K  1.5G   1% /dev/shm
none                  1.5G   92K  1.5G   1% /var/run
none                  1.5G     0  1.5G   0% /var/lock
none                  1.5G     0  1.5G   0% /lib/init/rw
/dev/sda2              50G   50G  277M 100% /media/Jatin
/dev/sda3              49G   46G  2.9G  95% /media/Study
/dev/sda5              88G   83G  5.4G  94% /media/Fun
/dev/sda7              32G   32G  177M 100% /media/Masti
/home/jatin/.Private   18G   12G  5.5G  68% /home/jatin
/dev/sda1              59G   57G  2.4G  96% /media/Windows7

My pysdm settings as mentioned in the above article are as follows:

The assistant options for the ntfs drives are as follows:

The file system is mounted at boot time.
Mount file-system in only read-only mode.

I have two files: /etc/fstab and /etc/fstab.BAK with their contents as follows:

fstab

# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc       /proc                proc  nodev,noexec,nosuid                0  0  
/dev/sda8  /                    ext4  errors=remount-ro                  0  1  
/dev/sda6  none                 swap  sw                                 0  0  
/dev/sda2  /media/Jatin         ntfs  nls=iso8859-1,ro,umask=000         0  0  
/dev/sda3  /media/Study         ntfs  nls=iso8859-1,umask=000            0  0  
/dev/sda5  /media/Fun           ntfs  nls=iso8859-1,ro,umask=000         0  0  
/dev/sda7  /media/Masti         ntfs  nls=iso8859-1,ro,umask=000         0  0  
/dev/sdc1  /media/sdc1          ntfs  nls=iso8859-1,ro,noauto,umask=000  0  0  

and fstab.BAK

# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc       /proc                proc  nodev,noexec,nosuid                0  0  
/dev/sda8  /                    ext4  errors=remount-ro                  0  1  
/dev/sda6  none                 swap  sw                                 0  0  
/dev/sda2  /media/Jatin         ntfs  nls=iso8859-1,ro,umask=000         0  0  
/dev/sda3  /media/Study         ntfs  nls=iso8859-1,umask=000            0  0  
/dev/sda5  /media/Fun           ntfs  nls=iso8859-1,ro,umask=000         0  0  
/dev/sda7  /media/Masti         ntfs  nls=iso8859-1,ro,umask=000         0  0  
/dev/sdc1  /media/sdc1          ntfs  nls=iso8859-1,ro,noauto,umask=000  0  0  

Initially, I had mistakenly created Silver Spoon as the mount location for /dev/sda2 and it was not booting Ubuntu. Then I fixed the problems by changing the fstab file contents by booting from a LiveCD and mounting the drive on /mnt/*.

PROBLEMS NOW

  1. When I look at the contents under /media, they are:

    jatin@jatin-ubuntu:~$ cd /media/
    jatin@jatin-ubuntu:/media$ ls
    Fun Jatin Masti sda2 sda3 sda5 sda7 sdc1 Silver Silver Spoon Study Windows7

With issues in all the directories in bold. When I open Silver or Silver Spoon, nothing shows up.

  1. Some of my ntfs drives get auto-mounted in READ-ONLY Mode, while others get auto-mounted in correct(READ-WRITE) mode.

  2. When I try to open my external hard drive, it says only root can mount it and a user can't. I know this can be fixed by simply removing the line for /dev/sdc1 from the fstab file.

QUESTIONS

  1. Are both these fstab and fstab.BAK files important? Shouldn't just one be there?

  2. How can I get my system in it's previous state, before I installed pysdm?

  3. When should I uninstall pysdm, before editing the fstab file or after?

share|improve this question

3 Answers 3

  1. fstab.BAK is a backup of your fstab file.
  2. Remove all the ntfs entries from your fstab file. The backup fstab will also mount ntfs partitions, so we can't use it.
  3. I think you should remove pysdm before you edit the fstab file.

I suggest you follow this guide to edit your fstab file.

share|improve this answer

-you don't need any programs to run a ntfs partition with auto mount and rewriteable options if you know how to use the terminal:

1) you'll need to know the UUID or /dev location of your ntfs partition; to find out both an easy way is to install GPARTED (gnome partition manager), right click + information.

2) create folders wherever you want to mount the ntfs partition.

3) with ntfs partition you cannot change file permission with chmod or chown commands after the partition is already mounted; you'll need to specify gid, uid and umask permission in fstab to mount them correctly. The first link below shows how to setup gid, uid and umask options and the second link will give you a tutorial on the structure of a fstab file:

http://ubuntu.swerdna.org/ubuntfs.html#permissions

https://help.ubuntu.com/community/Fstab

4) below are examples of two ntfs partitions on my machine:

UUID=yyyyyyyyyyyy /media/win7 ntfs-3g uid=1000,gid=1000,umask=0022,sync,noauto,nodev,noexec,nosuid,rw,nouser 0 0

UUID=xxxxxxxxxxxx /media/Hard-Drive ntfs-3g uid=1000,gid=1000,umask=0022,sync,auto,nodev,noexec,nosuid,rw,nouser 0 0

5) once you save the fstab entries and exit the text editor, run "sudo mount -a" to execute the fstab entries

-hope this was of some help


EDIT:

[UUID=xxxxxxxxxxxx /media/Hard-Drive ntfs-3g uid=1000,gid=1000,umask=0022,sync,auto,nosuid,rw,nouser 0 0]

  • slight correction to this entry since my last post: I have since removed the "nodev" and "noexec" options for this drive in fstab. Hard-Drive partition is used as storage for audio/video/etc. shared between Windows and Kubuntu. Because Hard-Drive is being shared, my download folder is set directly to it and I was unable to run "exe" files to install WINE programs.
share|improve this answer

You might try ntfs-3g package for using NTFS drives. In the fstab you need to write ntfs-3g instead of ntfs in that case.

share|improve this answer
    
I faced no such problems with the regular ntfs parameter. –  Oxwivi Mar 23 '11 at 12:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.