Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I tried to upgrade my Ubuntu 12.10:

The operation failed

E:GPG error: quantal Release: The following signatures were invalid: NODATA 1 NODATA 2

What's the solution? I need this upgrade.

share|improve this question
See if this answer helps: – Aditya Jul 4 '13 at 14:26

I have the similar error while using do-release-upgrade and having apt-cacher entries in my source.list. (Mine just disoplayed my apt-chacher address in place of the mirror address above)

I removed the apt-cacher entries from me /etc/apt/source.list and tried to run the upgrade again and this time it didn't give an error.

Still looking for a solution to use apt-cacher to do the upgrade though.

EDIT: I was editing my source.list adding the apt-cacher entries manually to the start of each line, but I found it I add this line to my /etc/ap/apt.conf file

Acquire::http { Proxy ""; };

the actual address that is giving the GPG error is displayed now.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.