Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use a Pentium IV PC [Hewlett-Packard HP D530 CMT(DC577AV)] containing the 'Intel Corporation 82865G Integrated Graphics Controller' with an HD TV set as a monitor. I have to use the integrated graphics because I was not able to install Ubuntu with an external graphics card and found no linux driver for the external card. Therefore I have to use a VGA connection.

Under Windows XP the resolution 1920x1080, 60 Hz, works precisely this way. 'Ubuntu 12.04.2 LTS' enables precisely the same resolution and frequency with a monitor that it recognizes, even using VGA connection. But the Ubuntu does not recognize my TV set and, with the TVset, it does not offer the 1920x1080 resolution.

According to Intel driver cannot detect my monitor and get native resolution and http://www.garrypassarella.co.uk/2011/04/23/add-undetected-resolutions-in-ubuntu/ I have got the resolution 1920x1080, 60 Hz for a moment using Terminal

$ xrandr  
Screen 0: minimum 320 x 200, current 1024 x 768, maximum 2048 x 2048  
VGA1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm  
   1024x768       60.0*  
   800x600        60.3     56.2  
   848x480        60.0   
   640x480        59.9   

$ cvt 1920 1080 60  
 1920x1080 59.96 Hz (CVT) hsync: 79.57 kHz; pclk: 206.25 MHz  
Modeline "1920x1080_60.00"  206.25  1920 2056 2256 2592  1080 1283 1293 1327 -hsync +vsync  

$ xrandr -newmode "1920x1080_60.00"  206.25  1920 2056 2256 2592  1080 1283 1293 1327 -hsync +vsync  
and  

$ xrandr --addmode VGA1 "1920x1080_60.00"  
.

I need to continue adding the resolution into the Ubuntu displays menu because, in a new run, the Ubuntu 'System Settings'...'Displays' offers only the former '1024x768 (4:3)' and '800x600 (4:3)' resolutions.

According to the http://www.garrypassarella.co.uk/2011/04/23/add-undetected-resolutions-in-ubuntu/ : I see no /etc/X11/xorg.conf file in that directory. I have tried
gsudo service gdm stop with a result
gdm: unrecognized service . I have tried
Xorg -configure with a result

Fatal server error:  
Server is already active for display 0

I am new with Ubuntu. Please advise me, how to add the new resolution into the Ubuntu displays menu, thanks,
Tomas Peceny.

share|improve this question
    
Please refer to the link I provided as the formatting of the relavent information is incorrectly displayed here. Lisa –  user254638 Mar 4 at 12:30

3 Answers 3

I was not able to apply fully the answer, but I have partially succeeded by making a batch file named davka1080.sh and placed at the desktop. It's content is derived from previous attempts, namely

#! /bin/sh

cvt 1920 1080 60  
xrandr --newmode  "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync   
xrandr --addmode VGA1 "1920x1080_60.00" #Czech comment

I have found its form at these pages, too, and in my /etc/init.d/README. The batch works by clicking its icon and 'Run'. Finally I have placed it as a start-up application for both users according to the How to run commands at login on ubuntu 12.04? and it works: the resolution is now really 1920x1080; I "only" need to close a remaining warning that the system could not apply the stored configuration for monitors. And it seems to me, according a known Video in VLC, that there is not a color depth 32 bit – full color. I shall ask another question about setting it

I hope that such an old hardware is usable with Ubuntu, also for precise showing photos taken at HD size and for watching (standard) TV and records as I am used to.

share|improve this answer

gdm was replaced by lightdm. So gsudo service lightdm stop might work. There exists no /etc/X11/xorg.conf because everything is meant to be detected without that configuration file, however you can create one yourself, see: https://wiki.ubuntu.com/X/Config/

If the IGP has a DVI output, please use that instead.

share|improve this answer
    
I have tried 'sudo service lightdm stop' with a result 'lightdm stop/waiting' . I tried 'Xorg -configure' with a result 'Fatal server error: Cannot move old log file "/var/log/Xorg.0.log" to "/var/log/Xorg.0.log.old"'. How should I continue, thanks, Tomas Peceny –  Tomas Peceny Jul 4 '13 at 12:53

But wait we need to make it stick

Creating the 10-monitor.conf

In order to create our new resolution we need to create /usr/share/X11/xorg.conf.d/10-monitor.conf So in the terminal run:

sudo gedit /usr/share/X11/xorg.conf.d/10-monitor.conf

note: you may have to change gedit to the name of your preferred text editor

this will open a blank text file, into which you want to paste the following:

Section "Monitor"
  Identifier "Monitor0"
  <INSERT MODELINE HERE>
EndSection
Section "Screen"
  Identifier "Screen0"
  Device "<INSERT DEVICE HERE>"
  Monitor "Monitor0"
  DefaultDepth 24
  SubSection "Display"
    Depth 24
    Modes "<INSERT MODENAME HERE>"
  EndSubSection
EndSection

The modename is the bit in quotes (so 1280x1024_60.00 in our earlier example). You can add additional resolutions that already exist in the list xandr shows just by putting them in quotes and adding them to the end of the modes line.

So for reference, mine looks like this:

Section "Monitor"
  Identifier "Monitor0"
  Modeline "1280x1024_60.00"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync
EndSection
Section "Screen"
  Identifier "Screen0"
  Device "VGA1"
  Monitor "Monitor0"
  DefaultDepth 24
  SubSection "Display"
    Depth 24
    Modes "1280x1024_60.00" "1024x768" "800x600"
  EndSubSection
EndSection

And you’re done!

Once you’ve saved 10-monitor.conf in /usr/share/X11/xorg.conf.d/, restart your computer and you should have your brand new resolution available and set as default.

excerpt modified by me used this on Ubuntu 12.04 this is working I reboot and it does not revert, source: http://samuelmartin.wordpress.com/2012/05/29/enabling-resolutions-in-ubuntu-12-04-lubuntu-12-04/

Only difference is in the beggining he used gtf 1920 1080 60 where as I used cvt 1280 1024 60

I hope this is of some use to some

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.