Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was testing Unity, but didn't like it. When I got rid of it there was nothing there, just a big white screen.

When I tried to apt-get gnome it gave me this error:

The following packages have unmet dependencies: 
 gnome: Depends: swfdec-mozilla but it is not going to be installed
E: Broken packages
share|improve this question
    
10.10 or 11.04? –  8128 Mar 23 '11 at 8:26
    
I think he is on Natty –  Manish Sinha Mar 23 '11 at 8:29

2 Answers 2

This may do it:

sudo apt-get install --reinstall ubuntu-desktop

Don't forget to logout and log back in, or restart for all the changes to appear.

share|improve this answer
    
So i tried that and everything was successfuil, everything unpacked. But after I restart there are no changes. Also when i log out normally there is a bar at the bottom with option like which environment to use(desktop/netbook) and some other setting but it shows up blank 9/10 times. Also i'm using 10.10 thanks. –  Nate Richie Mar 23 '11 at 16:54
    
Sorry follow up. I reinstalled Unity just so i could get some kind of environment and it seems like unity might be the default. On the log in screen where i can choose the environment it only lets me choose desktop/notebook, shouldn't it let me choose GNOME/Unity? –  Nate Richie Mar 23 '11 at 17:39
    
@Nate Can you add all this information to your original question so it doesn't get buried in the comments? Thanks! –  Jorge Castro Mar 24 '11 at 19:22

restart by pressing the power button, on the logon screen click on your account name and then select "Ubuntu desktop edition" instead of "Ubuntu Netbook Edition" from the third combo (left to right)... on the buttom of the logon screen

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.