Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i accidently deleted windows from another laptop and only have ubuntu to use on it now, during installation at the partitioning menu, when i click install now it says "no root file system is defined, please correct this from the partitioning menu" i have tried installing this several times and keep facing new problems each time. In the menu i have /dev/sda, /dev/sda1 ext4 118432 MB 2367MB used and /dev/sda5 swap 1599MB )MB used, how do i resolve this from here?

I know nothing about ubuntu at all so an easy step by step would be appreciated

sudo fdisk -l

Disk /dev/sda: 120.0GB, 120034123776 bytes 255 heads, 63 sectors/track, 14593 cylinders, total 234441648 sectors Units = sectors of 1 * 512 = 512 bytes Sector size (logical/physical): 512 bytes / 512 bytes I/O size (minimum/optimal): 512 bytes / 512 bytes Disk identifier: 0x0003eeed

Device Boot Start End Blocks Id System /dev/sda1 * 2048 231315455 115656704 83 Linux /dev/sda2 231317502 234440703 1561601 5 Extended /dev/sda5 231317504 234440703 1561600 82 Linux swap / solaris
share|improve this question
    
"during installation at the partition menu..". Which os are you trying to install? If you can access ubuntu then open terminal (clt + alt + t) then write (sudo fdisk -l) and paste the output here. Did you delete windows files or entire partition? –  shantanu Jul 3 '13 at 18:15
    
trying to install ubuntu to my hard drive and i deleted everything from windows, i can no longer use windows at all –  James Jul 3 '13 at 18:19
    
Please use proper formatting and copy&paste including the newlines. I am unable to improve your posts. Copy&paste in your question, select it all, then use the <$> button in the toolbar to format blocks of text that should be preformatted so it will looks the same as in your terminal. Thanks. –  gertvdijk Jul 3 '13 at 18:20
1  
@James Your question is not clear? Do you want to install ubuntu? Do you need a tutorial for that? or you want to install windows what you have just deleted? or you want to fresh dual boot (ubuntu and windows) system? –  shantanu Jul 3 '13 at 18:27
    
@shantanu im trying to install ubuntu as windows is deleted and no longer an option, ive tried installing a number of times but after install i couldnt download drivers for wifi as i had insufficient disk space, i deleted everything and am trying to use the whole hard drive in order to save the downloads as the space i was using before wasnt enough, so im trying to start a fresh by using the whole of my 110+GB drive, ive sought help so many ways but have had no resolve, im hoping this way is the last try as ive been trying two days straight to install and its becoming tiresome –  James Jul 3 '13 at 18:31

1 Answer 1

In the menu that you have mentioned, choose the item(partition) on which you wish to install Ubuntu and proceed.

share|improve this answer
    
i did, and it came up with "no root file system defined..." this happens on every partition i choose? –  James Jul 3 '13 at 18:13
    
Try setting the mount point of any partition to '/' and select that as the partition to install Ubuntu. –  Dharmaputhiran Jul 3 '13 at 18:20
1  
@James choose partition, click edit, set partition type ext4 and set mount as / now click ok –  shantanu Jul 3 '13 at 18:21
    
@shantanu thanks that worked out fine :) –  James Jul 3 '13 at 18:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.