Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I previously had Ubuntu 12.04. Then I installed Windows on another partition. Since then, the BootLoader did not start showing up when booting, and Windows started up asking me to log in. Then I made a bootable USB with Ubuntu 13.04 but when I booted from the pendrive, just a blank screen came with a message SecureBoot not enabled which disappeared as soon as it came. I searched ubuntu forums and found a similar question. The answer was to edit some lines of boot/grub/grub.cfg . Here is the link - http://ubuntuforums.org/showthread.php?t=2081912 .

After doing the edits suggested in the above link, the ubuntu installation screen came. I chose to upgrade my 12.04 to 13.04 . After the 13.04 was successfully installed I restarted but the Grub2 BootLoader did not show up and booted into Windows directly. Since then always this has happened. I also verified that 13.04 has been installed by selecting Try Ubuntu and checking the partition on which I installed 13.04. All the folders such as bin,boot,.... etc were present. Can anyone please inform how can I bring back the GRUB2 BootLoader with booting options into Windows 7 and Ubuntu 13.04 and I possible, set Ubuntu as the default OS to boot after the time-out period ?

My hardware specifications --
Lenevo Ideapad z570 with intel i5 ( 64 bit )

share|improve this question
add comment

1 Answer 1

up vote 0 down vote accepted

Windows had over-written the Grub menu. So I used Boot-Repair for re-installing Grub . Link - https://help.ubuntu.com/community/Boot-Repair

Source - Thanks to " grahammechanical " on UbuntuForums . Link - http://ubuntuforums.org/showthread.php?t=2159718#post12717318

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.