Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

First youtube started not loading videos, then almost all google products had problem. I had 12.04 and 12.10 on Asus N56VM. There was that problem. Now I have 13.04 on same machine. It still is. I have chrome, chromium and firefox. There is no difference. İnternet is generally fine. The problem is only on google products.

enter image description here

enter image description here

Edit:

  • Changing DNS not worked. I tried lots of DNS servers.

  • I tried with 3 different ISPs.

  • It is not a Flash Player issue I think, because the problem is on all of Google services (Gmail, Calendar, Maps), not only YouTube.

  • Tried disabling hardware acceleration option on Flash Player.

  • The problem is temporary. Some times Google.com, Gmail or Youtube work, some times not. Thus so difficult to track the problem.

  • These are some links related to my question. It is the same problem and no answer.

Edit 2: Question marked as duplicate. Okay, question is same (I noticed that when it marked, sorry). But the answer to that question is "change DNS" and I said it does not work for me.

Edit 3: I noticed that If I sing out from google account Youtube works well on all of my browsers(Chrome, Chromium, Firefox). I tried with different google accounts of mine on different browsers. Result is same. Finally I catch something to track this problem. If I'm signed in to google there is problem with google products.

share|improve this question
    
Interesting. Can you please try setting your DNS server to 8.8.8.8? If you need help doing so, tell us. –  Richard Rodriguez Jul 3 '13 at 16:51
    
Set your DNS server to 8.8.8.8 and apply. This solution will work everywhere and you will always get the domain that you have chosen. –  Radu Rădeanu Jul 3 '13 at 16:54
    
Domains have already setted to 8.8.8.8 and 4.2.2.1 . I tried changing domains. –  Can Jul 3 '13 at 17:03
    
this has nothing to do with DNS as this 3 statements above. Webpage is correctly displayed... –  Dee Jul 3 '13 at 17:09
3  
The only thing I can think of now is that your ISP is blocking streaming video. I see the exact same a lot on hotspots, 3G/mobile internet, etc. as being a policy of the internet service. Do you have another network/ISP you can connect the computer to and check again? –  gertvdijk Jul 3 '13 at 17:31

2 Answers 2

I had similiar problem with youtube videos not playing. I am using chrome browser mostly, so I will explain the method that fixed my problem.

  1. Open the chrome settings

  2. Open advanced settings.

  3. On the Privacy section click content settings

  4. Under the Cookies click the Manage exceptions and set www.youtube.com and youtube.com as blocked.

So the basically the problem is cookies. Above procedure solved my problem.

share|improve this answer
    
I tried with 3 different browser. –  Can Jul 12 '13 at 16:35
    
Sorry it didn't solve your issue. I thought we had the same problem. Blocking the cookies from youtube solved it for me. Maybe you can check your /etc/hosts file contains any entries related to google.com, youtube etc. If there are try to delete those and reboot the computer. –  Johankor Jul 12 '13 at 16:55
    
I checked hosts file. There is nothing about google our youtube. Thanks for your trying. This problem is really annoying. I'm afraid it will cause me to pass windows. –  Can Jul 12 '13 at 20:39
    
Hey you were right. It is cookie issue. Did you find a solution to use Youtube with signed in ? –  Can Jul 15 '13 at 2:23
    
I am glad it worked. I don't use youtube as signed in, so no solutions about it yet. –  Johankor Jul 15 '13 at 5:54

What I see on your screenshot, the youtube pages work OK, but video does not. This is because you missing support for any flash/flv player. This (How do I install Adobe Flash player?) will serve you very well.

share|improve this answer
3  
The flash/flv player is OK. Otherwise, you get on Youtube a warning in this sense. If the flash player would not be present, you would not see any menu for the video. –  Radu Rădeanu Jul 3 '13 at 17:27
    
It might be a flash player issue because when I visited this page adobe.com/shockwave/welcome I see a warning 'No plug-in available to display this content.' However on this page adobe.com/software/flash/about I see 'You have version 11,8,800,96 installed' and playing flash above. google.com still have same problem. But not everytime I try. Sometimes it loads immediately. Sometimes doesn't load for five minutes :S –  Can Jul 3 '13 at 17:33
    
I had similar behaviour on fresh xbuntu install, basic flash banners was animated, but no video from youtube.., so some can say they know everything... but they dont. I do not remember exactly how did I solved, but I did play with different flash packages and now it is just working. –  Dee Jul 3 '13 at 18:20
    
It is not only Youtube. Almost all of Google products are same. Even Gmail. Thus I think its not flash player issue. –  Can Jul 3 '13 at 19:38
    
ok, then forget it –  Dee Jul 4 '13 at 10:50

protected by Community Jul 15 '13 at 13:20

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.