Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Hello this is the response I get from ifconfig. Now I have two eth0 things being showed up. I need to delete the second one which says eth0:avahi. I posted my ifconfig's response on a site as I has problem using wired internet, and they suggested to remove the eth0 avahi, to get internet.

But I am a newbie to linux networking and have no idea how to delete this.

response for ifconfig

eth0 Link encap:Ethernet HWaddr 18:a9:05:22:cd:f9
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:28 Base address:0x4000

eth0:avahi Link encap:Ethernet HWaddr 18:a9:05:22:cd:f9
inet addr: Bcast: Mask:
Interrupt:28 Base address:0x4000

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:796 errors:0 dropped:0 overruns:0 frame:0
TX packets:796 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:64016 (64.0 KB) TX bytes:64016 (64.0 KB)

wlan0 Link encap:Ethernet HWaddr 00:26:82:3c:ac:27
inet6 addr: fe80::226:82ff:fe3c:ac27/64 Scope:Link
RX packets:52142 errors:0 dropped:0 overruns:0 frame:0
TX packets:30404 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:60816983 (60.8 MB) TX bytes:4160159 (4.1 MB)
share|improve this question

Avahi is a daemon (a service) which is responsible for several things, including attributing you an IP address when DHCP (automatic IP address from a DHCP server on the network) fails.

The fact that eth0:avahi appears means that the system failed to get an IP on the eth0 interface (your wired network interface).

Normally, NetworkManager should take care of attributing an IP automatically to eth0. However, you could try to force it. Your /etc/network/interfaces doesn't list eth0, so what you can try is the following.

First, edit /etc/network/interfaces (with sudo gedit /etc/network/interfaces for example) so it reads this:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

This will tell the computer to consider getting an IP automatically for eth0. Then, restart the network with:

$ sudo /etc/init.d/networking restart

If it still doesn't work, there might be other issues:

  • are you sure there is a DHCP server on your network? If there isn't, you'll have to setup the IP address manually;
  • if you have a DHCP server, it probably means that your problem is a hardware issue. Check that the cable is well plugged and lights are on on both sides of it.
share|improve this answer

The ethX:avahi (or whatever your interface's name is) will disappear as soon as you get either a fixed or dynamic IP from e.g. a router.
In case you're using the command line you can use this:
sudo ifdown eth0 && sudo ifup eth0
sudo /etc/init.d/networking restart

Although the avahi interface can be annoying, it should only show up when you didn't get any IP. Like Elias said you can also try to disable to daemon by editing /etc/default/avahi-daemon to have it look like this: AVAHI_DAEMON_DETECT_LOCAL=0

To sum up I suggest you simply restart your networking and if there is a router willing to give you an IP then your avahi interface should be gone.

This is my interfaces file just in case:

auto lo
iface lo inet loopback
auto wlan0
iface wlan0 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

ps: as you can see I'm using wpasupplicant and got rid of network-manager but that's unrelated to the avahi issue.

share|improve this answer

Hello I am new at ubuntu as well. I had a similar problem to the one described above and I caused it myself.

My linux version is Ubuntu 10.04.1 LTS and I use eth0 to connect to a dsl modem/router which also is a dhcp server for the pc in eth0. I was reading a book about linux and tried to use the "ifdown eth0" and "ifup eth0" command but I was getting the following results.

sudo ifdown eth0
Ignoring unknown interface eth0=eth0.
ifdown: interface eth0 not configured

sudo ifup eth0
Ignoring unknown interface eth0=eth0.

I look it up in the internet and it found that in the /etc/network/interfaces file there should have the record I show bellow for the eth0 in order for these commands to work.

#The loopback network interface 
auto lo
iface lo inet loopback

#The primary network interface
auto eth0
iface eth0 inet dhcp

I only had only the lo record in my file and although I connected to the internet without a problem from the time I installed ubuntu I added the eth0 record as well. As it is mentioned above I restarted the network and everything seemed to work just fine. And I could use the ifdown and ifup commands.

Until I opened my pc again after a pc shutdown and a CPE restart. I couldn't not browse in the web and if remember correctly I couldn't even ping my router. From what I understand the eth0 was not getting an IP address from the dhcp of the router. Also I had the exact same ifconfig result that is shown above in the threads beginning.

In my case I could solve my problem by doing "sudo ifdown eth0" and then "sudo ifup eth0". The eth0 got an IP address and everything worked just fine. Of course every time I had a shutdown I had to repeat the process.

Today I looked the avah that is mentioned in the ifconfig response and I checked to see if it was turned on my pc.

$ cat /etc/default/avahi-daemon
# 1 = Try to detect unicast dns servers that serve .local and disable avahi in
# that case, 0 = Don't try to detect .local unicast dns servers, can cause
# troubles on misconfigured networks

I guess it is turned on although it doesn't mention anything about the dhcp.

In my case i remove the eth0 entries from the /etc/network/interfaces and I got back in the situation I was before. I cannot use the ifup and ifdown command but after a shutdown eth0 got it's IP from my routers dhcp without a problem. What I haven't done is set my avahi setting to 0 and then add the eth0 in the /etc/network/interfaces file to see what happens.

I hope my writtings help and not confuse.

Regards Elias

share|improve this answer

Check if avahi is listed in your /etc/network/interfaces file. If it is, delete it from there.

share|improve this answer
auto lo iface lo inet loopback this is the content in /etc/network/interfaces file – sai Aug 26 '10 at 17:10

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.