Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Skype doesn't find my audio input. If I click on the "Microphone" no other suggestions appears, my web camera works.

In windows everything works.

Skype sound options

This is my audio preferences. enter image description here

audio settings.

enter image description here

share|improve this question
    
I had the exact same settings on Ubuntu 10.10 (Although that's now been updated to 11.04 :P). I have a feeling that the answer will work for me as well. –  jrg Mar 22 '11 at 22:48

3 Answers 3

up vote 2 down vote accepted

The only way I've found to make my internal mic work in my laptops is to use pavucontrol (install it from the homonymous package) and disabling the volume of a channel (the right or the left one), since most of microphones are mono in fact.

This is an huge workaround, by the way. I guess that this annoying bug should be fixed somewhere!

Pavucontrol - Input volume settings

share|improve this answer
    
Why should I disable one mic? I don't get it what should I expect? What is your point? –  Alvar Mar 24 '11 at 19:08
1  
I know I didn't ask this question, but upvoted. Worked for me. FINALLY I HAVE SKYPE WORKING. :D –  jrg Mar 24 '11 at 19:35
1  
@Alvar I'm not disabling a mic, but disabling a channel. Many internal mics are considered as stereo by PulseAudio (or alsa?) while they are really monoo. Using both channels causes the microphone not to work at all! –  Treviño Mar 25 '11 at 10:56
    
WOW! This is amazing! but it should be installed form the begging or it should be done in a better way... It's not that big of a workaround just install it and disable a mic simple! :) –  Alvar Mar 25 '11 at 22:25
    
I have a problem, this answer doesn't work for me now! In this newer version I have to adjust both channels, I can't just mute one. please help!!!! :( –  Alvar Sep 5 '11 at 21:40

Under Sound Preferences, please post the "Hardware Tab" in order to check your profile, which should use at least an output + an input being in use. Otherwise, your hardware is not using the input profile which can be chosen right there.

This answer may be changed after your posting in order to give you further details. Here is a sample. Thank you.

enter image description here

Edit

Here is the conversation in the general chat room.

share|improve this answer
    
Sorry none of them works, I don't have as many as you do, but still none of them works. –  Alvar Mar 22 '11 at 23:11
1  
If you are in a Laptop, the Internal Audio Analog Stereo may refer to a device which is not connected to your sound device. This is the case with the Compaq Presario V3000 (V3616LA) and some netbooks (Acer, eMachines, Benq, etc.), try connecting a microphone into the Mic Jack (external connector) and check what happen. This may solve your issue as the device is named but not being used by any physical device. –  Geppettvs D'Constanzo Mar 22 '11 at 23:14
    
I doesn't have an external microphone to plug in sorry. new screenshot uploaded. –  Alvar Mar 22 '11 at 23:20
1  
Choose the "Analog Surround 4.0 Output + Analog Stereo Input" and check it again. –  Geppettvs D'Constanzo Mar 22 '11 at 23:24
    
join the chat man! Allan has helpt a lot.. –  Alvar Mar 22 '11 at 23:35

Make sure to use the latest Skype beta version for Linux from http://www.skype.com/intl/en/get-skype/on-your-computer/linux/. Older versions do not work properly with Pulse Audio. Also uncheck the "Allow skype to automatically adjust my mixer levels", it caused a lot of trouble for me. After that, reset all your mixer levels by opening a command-line and running alsactl init.

share|improve this answer
    
Error: A later version is already installed and that was the latest version on their site. –  Alvar Mar 24 '11 at 19:07
2  
The ubuntu repository has made some localized changes to the skype package, thats why you're seeing that. Linux skype is in sorry shape and needs some serious revisions. –  lazyPower Mar 24 '11 at 19:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.