Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to install Ubuntu on Windows 8. My system does not have the SecureBoot and UEFI option. I downloaded the Ubuntu 12.04 ISO from the website. It contains wubi.exe, but when I run Wubi it starts downloading the Ubuntu ISO again.

I tried the option of putting the ISO and wubi.exe in an empty folder and then running it, but it still downloads a new ISO. Why can't it use the ISO I already have?

share|improve this question
What does the logfile say? Check in %TEMP%\wubi-12.04.2-rev272.log or pastebin the entire file and post the link here so we can see it. – bcbc Jul 3 '13 at 6:47

Most possibly you have downloaded (the default downlaod) a 32 bit ISO where as your machine support 64bit. So wubi detects it and tries to download 64bit ubuntu ISO.

To force using 32bit, open the folder where you stored wubi.exe and ISO. Now right click while pressing Shift, click on Open a command window here

Now execute Wubi.exe with parameter --32bit, the command should be like Wubi.exe --32bit

Few more points for troubleshooting:

More FAQs and details :

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.