Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried asking this in the Unix & Linux stackexchange, but this may be a better place.

I have been trying to install some Gnome extensions from the site https://extensions.gnome.org. I get the dialogue asking if I want to install, but after I select yes, it fails silently. This is the behavior using either Firefox or Chromium. I have checked to make sure the Gnome Shell Integration plugin is installed and enabled for both Chromium and Firefox.

My operating system in Ubuntu 12.10, and my version of Gnome is 3.6.3.1. I have made sure (using sudo apt-get update) that everything is up-to-date. I have tried restarting, but to no avail. What am I doing wrong, and how do I fix this (or what is a good workaround)?

NOTE: I have the gnome-tweak-tool installed, and it does not show any extensions as installed. There is nothing happening after I confirm that I want to to download the extension.

EDIT: Extensions are now working. I do not know why. Maybe it was restarting. I will mark the below answer as accepted because it gives good information that may help others. I would suggested to anyone in my position just making sure everything is up-to-date, restarting, and then checking every so often to see if it is working.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

To be able to install and use the GNOME shell extensions we need the following packages:

We can then install extensions by turning the switch on the upper left corner of the GNOME extensions download page to ON. Turning this switch to OFF will disable the extension.

enter image description here

Loaded extensions or themes can then be further controlled with the GNOME tweak tool.

enter image description here

share|improve this answer
    
Right. I know this. I have both things and they are updated. As I state in my question "I get the dialogue asking if I want to install, but after I select yes, it fails silently." This is an excellent answer to a question that wasn't asked... –  MirroredFate Jul 3 '13 at 15:55

Unity session doesn't support gnome extension. You can use gnome session if you want. Install gnome-shell with apt-get install gnome-shell Log out and log back with gnome session. You can see them.

Here is a link to do it in detail:http://www.filiwiese.com/installing-gnome-on-ubuntu-12-04-precise-pangolin/

share|improve this answer
    
I have it installed. It changes nothing. :/ –  MirroredFate Jul 3 '13 at 1:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.